User Avatar Image

Activation by TT account fails, serials works

posted by fpostma on - last edited - Viewed by 318 users
I have so far had to activate all my TellTale stuff (S&M season 1 and 2,SBCGFAP ep2) via the serial-number input because activating it via the telltale account method always fails.

I do get the current forum-threads thingie on the launcher, so it can access the internet. Any further ideas what I should check? Is there a list of requirements to get the TT activation method (which seems to be the preferred one?) to work?
7 Comments - Linear Discussion: Classic Style
  • User Avatar Image
    Jake Telltale Alumni
    Assuming you are entering your password correctly, it should work.

    Have you tried using your email address instead of your username when logging in?

    If you really want it sorted out, I recommend writing to [email][/email], but a cursory glance at your user account in the TTG admin system looks totally normal to me.
  • I've only tried my email address actually, password seems to be ok since it works on the website. There's only one account for all the TT functions, e.g. forum/buying/website ... thats all one account right?

    Will mail support once it really starts to bug me (still have SB ep1 to test with), thanks for the fast reply!
  • What error message do you get when you try it?
  • Emily;91056 said:
    What error message do you get when you try it?
    Just that something went wrong, didn't really read it that closely. But nothing specific as far as I could see. Anything specific you want me to try with StrongBad's episode 1? Haven't activated that one yet (bought the season to play episode 2, but will get to ep1 eventually don't worry ;-)
  • Just try logging in on the initial log-in screen, and let us know what it says when you try that.

    If it doesn't work and you click "take me to the demo", look at the log-in tab and see if it says you're already logged in or not. Also let us know if you're able to see the community content (blog posts, forum posts, etc.) or if you see a message that says "unable to access community content". (Never mind, you answered that in your original post.)

    (If you want to try it out on one of the games you've already unlocked, you can go to the game launcher and press ctrl-shift-minus to deactivate it.)
  • Hmm.. odd.. I firmly intend to blame my browser (Firefox 3.01, winXP) but it seems my password was different than I thought?

    Weird thing was that I couldn't logOUT of the site at all. Only way I managed to get that done was remove ALL cookies from and (both had a ttg_username/password cookie btw) and finally I was logged out.

    Logging in then without using the remembered passwords revealed that the password I used was incorrect. A quick scan of my email-inbox solved that problem. That same password also works nicely for activation of episode1 (though it appears this way of activation is actually slower then serial-number activation?).

    Soooo... most of this was actually my own fault, sorry about that :(

    All is solved now, which is good :)
  • It's slower because account authentication is a mechanism we built on top of the normal serial number system to make the serial number process more transparent to repeat customers. That means it requires an additional request to authenticate your login before the one to actually unlock the game.
This discussion has been closed.