"Buy Full Version" Button Doesn't Work.

edited September 2005 in Game Support
Whenever I press it, the screen just flashes white and gives me info about the secure puchasing.

I can't find anywhere else to purchase the game (not even on the website), so I'm assuming that this button is the only option.

Please help.

Rubber John.

Oh yeah, I downloaded it from the official site and not Fileplanet.


  • Options
    edited September 2005
    I also have problems buying the game. Says "Connecting", then most of the time I get a blank screen, or when I try to checkout, I get a "Ressource not available" error.

  • Options
    edited September 2005
    I had this problem at first; what I had done was I ran the downloader as one user, then ran the installer that the downloader saved as another user (because I'd need administrator access to install, of course). That caused the problem you explained, where it appeared to refresh the page.

    Just before sending off an email to support explaining how I'm dying to give them money, if only they'd let me, I decided to try running the downloader and installer as an administrator and everything worked fine.
This discussion has been closed.