User Avatar Image

Can't change the language in Ep. 3 (Purchased via steam)

posted by NewWendigo on - last edited - Viewed by 1.3K users
The game is supposed to be in 5 languages: english, french, german, italian and spanish; but I started playing the last chapter and I noticed that the game was completely in english, so I tried to change the language by clicking the game in the game list and selecting properties, but there isn't any option to change the language.

Why is this? Is Telltale releasing the translation later because they are busy with Monkey island or they will never translate it?

If it was the second, I would be very disappointed because I bought the game thinking that all the chapters would be translated to spanish.

Sorry for my english and thanks.
10 Comments - Linear Discussion: Classic Style
  • With the normal download versions (from this site) you choose the language on installation (you can't change it afterwards). I don't know if it's the same with the Steam-version though.
  • Don't worry, you are not alone. I've also buy the game on Steam and the tab "language" is not here. So can the developper tells us how to put the subtitle in a other language than english ?
    Thanks a lot!
  • Hey guys, we are looking into this. It may be a problem on Steam's end, but I'm not sure yet. We will update you when we know a little more, but we should get it fixed fairly soon.
  • Thanks Will and the other people who tried to help.

    I can't wait to that translation to be released and start playing Ep.3
  • From the fine and helpful folks at Steam: "I just tested the fix on our internal system and it works correctly, so I’ve rolled it live. Restart Steam and you should have language options for Ep3, now." Those guys rock.
  • Thanks a lot Will! You're awesome! Continue to create such great games!
  • I'm sorry but I've restart Steam but I still can't choose my language. Any idea ?
  • hmm, looking into this again.
  • So I've personally never seen the "choose your language" option, but it looks like if you change the language of Steam as a whole the game should work in that language. We just jumped over to German and it worked fine.
Add Comment