User Avatar Image

ToMI will only launch from installer

posted by deerpark on - last edited - Viewed by 297 users
Hmm got a real strange issue here.
I installed the game and at the last page of the installer you get the option of launching the game. I selected this option and the game worked just fine. I played through the first part, getting to Flotsam Island and then exited the game and went to bed.

Today I of course wanted to play the game again, so I hit the shortcut to launch the game and nothing. The monkeyisland101.exe appears briefly in the task manager and then disappears. I've uninstalled and reinstalled the game several times now and I can replicate the behavior I've described every time. The game will launch from the installer, but never from the shortcut or monkeyisland101 executable.

My system specs:
Windows 7 RC1 64 bit
Core 2 Duo @ 2.13 GHz
Nvidia 9600M GT
5 Comments - Linear Discussion: Classic Style
  • Just to make sure, does it still give you the problem if you reboot between launches?
  • Yep rebooting does nothing. The game simply refuses to launch in any way except from the installer. I've tried using compatibility mode for XP and Vista. I've tried disabling my Eset NOD32 Anti-virus and Comodo Firewall. I've even kept the installer open at the last page (where you select whether or not you want to launch the game when you hit finish) and then navigated to the game directory and tried to run monkeyisland101.exe, nothing. But if I go back to the installer and hit finish with the launch game option checked, the game launches and all is well.

    Only thing I haven't tried yet is launching the game in safe mode. Actually I think I'll try that now.

    Okay, progress, sort of. In safe mode the game launcher comes up when I run the game exe.
  • well if it's running in safe mode, one thing you can try is a clean boot. That will turn off just about everything (much like safe mode). If that works, then it's a case of seeing which program is causing the problem. These steps are for vista, but hopefully they will work for Win7:

    To Boot Clean in Windows Vista

    1. Click Start --> Run --> Type MSCONFIG --> Click OK
    2. On the General tab, choose Selective Startup
    3. Uncheck Load Startup Items
    4. Select the Services tab
    5. Check Hide all Microsoft services
    6. Click Disable all
    7. Click on OK
    8. Click Restart.
    9. After reboot, run game to see if it works.

    After performing the necessary steps, restore your system by doing the following:

    1. Click Start --> Run --> Type MSCONFIG--> Click OK
    2. On the General tab, choose Normal Startup
    3. Click Ok
    4. Click Yes, when asked to restart your computer
  • Okay problem solved.
    I updated Comodo Firewall to the latest version (v. 3.10.102363.531) and this did the trick. Apparently Comodo wasn't completely disabled when I tested last time.

    But thanks for the help.
  • Yeah, it can be tricky disabling firewalls and antivirus. Great to hear you got it working!
This discussion has been closed.