User Avatar Image

SBCG4AP - Not saving [Steam on Vista]

posted by Joren on - last edited - Viewed by 637 users
I just saw the whole season come up on Steam and since I come from a long line of $35 bucks-havers, I thought I would get it there. So I downloaded the episodes through Steam and decided to give episode one a whirl. After playing for a bit, I tried saving and loading only to find that my game and all my preferences had been DELORTED.


* PC game
* Running on Dell Inspiron 1720 with current drivers and reference nVidia notebook drivers for the GeForce 8600M.
* Windows Vista service pack 1
* Season 1 purchased via Steam.
* Running as Administrator
* UAC is and has been turned OFF - I will not have Vista repeatedly second-guessing me.
* Local files have been verified (Steam) - this is not a corrupt download


SBCG4AP will not save or load any games, and also does not remember user preferences. It doesn't matter what episode.

Obligatory Steps to Reproduce:

1. Start a new game.

2. After the introduction stuff, click Gear icon or press Escape to get to menu.

3. Click Save/Load

4. There are four grayed-out slots and only one button. It's on the left side of the first slot, and is blue with a little arrow. I click it.

5. Message appears on screen: "Game Saved". However, nothing has changed. No save-title appears, and no time-stamp. My screen looks like the screenshot provided from someone else's post:


Try loading a game:

1. Click on "Quit it". Choose "Quit to Main Menu."

2. We are going to attempt to load the game that was supposedly saved. Click on "Save/Load".

3. Notice the distinct lack of any saved games. All four slots are empty, and there is only one button next to the first slot. This is the SAVE button, and clicking it results in The Paper saying "Sorry, you can't save right now." THERE IS NO LOAD BUTTON, NO SAVE TITLE, NO TIME-STAMP OF ANY KIND.

Now, I want to see if the game remembers ANYTHING AT ALL. Perhaps, if I can get it to remember something intelligent, I can get a batch of those special Grumblecakes. So, we are going to modify some preferences.

1. Load SBCG4AP. We are going to try changing some preferences, just for kicks, and see if it remembers them. Go to Settings. Change the resolution, or hint level, or whatever you want. For most dramatic example, try changing "Full Screen Mode" under "Graphics Setup."

2. Click on "Quit it." It helpfully asks, "Are you sure you want to quit the game?" choose "Yep!"

3. Load SBCG4AP again. Click on "Settings". Notice that the preferences have NOT been saved; they have ALL been reset to the defaults.

This is most apparent if the preference you changed was the "Full Screen Mode" under "Graphics Setup." It will load in the default letter-box, not full-screen.

So we have established it does not remember anything at all. Now lets see if we can find out whether or not any new files have been created.

1. Back in Windows, go to Start Menu.

2. Select "Documents"

3. Look for folder called "Telltale Games." A ha! There IS a directory called that! Double-click that folda!

4. Look for any episode folders. In my case, right now there is a "homestar ruiner" folder. double-click that one, too

5. Notice that the entire folder is empty. Not a SINGLE file. But wait! Maybe the file is set to "hidden"!

6. Try browsing with "show hidden files" / "show system files" enabled from Folder Options. Or if you're like me and Vista's user interface really frustrates you, you can go to a command prompt and try "cd %userprofile%/documents/telltale games/homestar ruiner" and then "dir /ah". Silly Vista. It uses NEW computers!

7. No files. Nothing.

Ok, so maybe we have a corrupted download.

1. Go to Steam.

2. Right-click the episode of your choice.

3. Select Properties.

4. Go to "Local files"

5. Select "Verify integrity of game cache..."

6. Notice that verification succeeds.

You could also try a different episode. This calls for a DO-OVER!!!

1. Load a different episode of SBCG4AP.

2. Try the above steps and see if anything changed.

3. What does the game do differently Richie? Nothing. Absolutely nothing.


Try to dig up some more info, or perhaps some ancient ruins under Strongbadia:

Steam insists on putting everything in its own directory. In our case, the game seems to be stored in "C:\Program Files\Steam\steamapps\common". Under episode folder, for example, "homestar ruiner", there is a lone executable, some dll, some vdf file, and some subfolders. Let's see if there is a security issue.

1. Under My Computer (or Windowskey-R if you're like me) go to "C:\Program Files\Steam\Steamapps\Common

2. Right-click on an episode folder. Select properties.

3. Select "Security"

4. Select "Advanced" (all good things are hidden behind Advanced; it's a general rule of life)

5. Verify that "Administrators" has full control of everything.

6. Click "Edit"

7. Check box that says "Replace all existing inheritable permissions on all descendants..."

8. Click OK to your heart's content. Turns out it was just a cap off of Coldonesdry.

9. Try running the game. Nothing has changed.

Obligatory what-if: Did I download a virus? Did I download 400,000 viruses?

1. Run Edgar's Virus Hunter (edgarware.exe) or your scanner of choice. In my case, no viruses. Of course, one should probably also run Edgar's Step-mom's Sister's Spyware Scanner (programmed entirely in mom's attic). Nope, no spyware.

This is all I have energy for right now. Thoughts?

Oh, and happy Decemberween everyone!

-- Joren
2 Comments - Linear Discussion: Classic Style
  • Guess what? I found a bug.

    I tried using Process Monitor to examine where it was trying to write a file. Here's the summary: Because the expected save location is in the Documents folder, the game tries to get the path to my user Documents folder.

    However, my user name is in Unicode, and apparently this game does not handle Unicode correctly. My Windows Vista profile name is ジョーレン コームズ, but SBCG4AP has decided to creat an alternate reality, where it doesn't have to spell correctly, mangling my user name from ジョーレン コームズ to ヘョーレン ビームペ.

    I did notice in Process Monitor that all the path and file names seem to have been formatted to be lowercase. Is it possible that some kind of string formatting function is being used, which doesn't know what to do with Japanese Katakana? Here are the two strings side by side so you can see where it went wrong.

    ジョーレン コームズ
    ヘョーレン ビームペ

    ジョ became ヘョ, コ became ビ, and ズ became ペ.

    So for anyone else out there who has this problem and wants a short term fix, there are two things you can do:

    If you're The Cheat:

    1. Use "Procmon" by Sysinternals to monitor the game and figure out what user name it is trying to write to. Note any "PATH NOT FOUND" errors.

    2. You will want to create a junction inside your C:\Users folder. (C:\Documents and Settings in XP or 2K) The link's name should be the misspelled username found above, and the link's target should be your correct user folder.

    To make this link, in Vista you can use the command prompt. There's a command called mklink. In XP or 2K, you should download NTFS Link.

    If you're Homestar Runner:

    1. Just use a different Windows profile with a non-Unicode name. Of course this profile should be an administrator. It's less complicated, but it's not as cool and you don't get as much street cred.

    Long-term Solution

    SBCG4AP is gonna need to learn how to spell. Can I have my Grumblecakes now?

    -- Joren
  • Thanks for posting about the problem and what you were able to figure out. We're closed for the holidays right now, but we'll make sure to take a look at this when we're back at work in 2009.
This discussion has been closed.