User Avatar Image

Can't save progress in Monkey Island episode 1 - UAC is disabled

posted by Nebu on - last edited - Viewed by 966 users
It's not only save games, but also my preferences (screen resolution, whether or not subtitles are turned on, etc.) which are not saved.

UAC is disabled, and I am running from an admin account.
21 Comments - Linear Discussion: Classic Style
  • User Avatar Image
    Ok, UAC being disabled is the culprit.
    If it is enabled, it works behind the installer translating paths (and registry keys) that you don't have regular access (even as an admin on Vista/W7*)

    Short and easy way to solve this: enable temporarily UAC and run the installer
  • You mean I should uninstall the game, enable UAC, install the game, and then I can disable UAC again and play normally?
  • jmm;154456 said:
    Ok, UAC being disabled is the culprit.
    Shenanigans. I have UAC disabled on my Vista admin account, and have had for quite some time now. No problems installing the game, saving, or saving preferences.

    Nebu, where do you have the game installed? In the default Program Files, or elsewhere? I know other games (Elder Scrolls III: Morrowind, specifically; others on hearsay) do have difficulties with save games if they're installed to the default Program Files folder. Try reinstalling the game elsewhere (say, C:\Games\Telltale).
  • It's probably installed in the default location (Program Files), since I don't remember ever specifying where to install it. I'll try both of your solutions later tonight.
  • I have the same issue, and I believe I know a possible cause.

    The location the save files are stored in (on Vista) is Users\\Documents\<...> which doesn't exist on my machine - the Documents folder is repointed to my E drive. This, I suspect, is what causes no gameplay or settings to save.

    Unreal Tournament has the same issue, with it being resolved by providing a "-nohomedir" command line flag (or similar, I can't recall if that's the exact command) which saves all preferences, etc. to the install directory.

    A possible cause for Telltale QA to look at...(if they're listening)...
  • I had the same problem on my Vista64 system.

    My Documents folder is set into another location than the default one (\Users\\documents). Many others game that use Documents system folder has no problem at all writing savegames and settings into the new location, but TOMI does. I had to move Documents folder to default position in order to play the game.
  • User Avatar Image
    DjNDB Moderator
    Faniel;159437 said:
    I had to move Documents folder to default position in order to play the game.
    Have you tried just linking to it instead?
  • DjNDB;160111 said:
    Have you tried just linking to it instead?
    I've tied and the result is the same. Seems like the game is not writings any saves/prefs unless the documents folder is the default one.
  • User Avatar Image
    It's pretty clear that changing the default Documents location in Vista on up is broken. What I need from everyone is the EXACT steps you took to change the folder location. This allows us to have reproduction steps in fixing this bug.
  • I'm not sure I can remember the exact steps in changing the path of the "Document" folder, since this was done a long time ago (when I first installed Vista), but I suspect this is how I did it, since this is how I would do it today:

    [*]Click on the Start button
    [*]Right click on the "Document" entry, which should be right below your user name.
    [*]Select "Properties" from the pop up menu.
    [*]Go to the "Location" tab.
    [*]Enter a new location.
    [*]Click the "Move" button.

    Here's where things get a bit fuzzy: It'll probably ask you whether you want to move whatever is currently in your documents folder to the new location. I think I said "yes", but I'm not 100% sure about that.

    Another thing to note is that it seems everyone who is affected with this bug has moved their location to a different drive (I've set my location to "D:\"). Perhaps saving works fine if the location is on the same drive (i.e. "C:\"), but it fails when it's on a different drive?
This discussion has been closed.