User Avatar Image

TOMI - poor video mode choices

posted by Derrick on - last edited - Viewed by 648 users
You folks have seem to gone a step backwards and removed the ability to select any video mode your card/monitor supports. W&G allowed any mode you want and it would crop to the 16:9 view.

For some reason in TOMI you went back to the old method of only allowing resolutions that TTG wants. There is no need for this when you crop the view window to 16:9 anyways.

Now I can no longer select 1176x664 or 1768x992 so the game will fit on my overscaned HDTV.

Now in TOMI, I can not see all the text on the screen. I'm going to try figuring out the prefs.prop file again to get the support you do not allow. But I may just end up asking for my money back.

I can't even read the text describing the new mouse movement method, which seems quite similar to my mouse movement script for W&G. ;)
13 Comments - Linear Discussion: Classic Style
  • Derrick;150281 said:
    I'm sure its not the latest version. :) I created the program. I added a feature to read the video mode. I'll try to upload it tomorrow.

    Anyways you are right. It now seems to work for me. I have forced it to 1176x664.

    My brain must have malfunctioned due to the same overload that was happening to the TTG site all day. :)

    Thanks. And I'm glad people are finding the utility useful.
    Lol well kudos to you for making my life easy :-)

    Thanks a lot dude, I was seriously peeved when I started the game and couldn't play it right. I quoted it as the latest even if there is only one version being that it actually worked on ToMi. Muh bad :-)
  • Jake;150000 said:
    I had thought that video mode selection was engine-wide so when it was fixed for W&G it would be in Monkey as well. I'll ask around and see if something has actually changed deliberately, or was just a bug, and if we can fix it moving forward in ep 2.

    Thanks for the quick reply and for looking in to it.

    Now that I found I can patch the video mode with my utility, I no longer need to ask for a refund. :D Now to play the game.
  • I updated the Widescreengaming forum post with the newest TTRes tool.

    The wiki still has the old version. I will notify the moderator.

    New version supports resolutions down to 640x480 and has the option to just read the current resolution.
  • First off, a HUGE thank you to Derrick for making this tool, i was really surprised when i couldn't select 1360*768 which is probably the most common resolution on midrange LCD televisions. However i'd just like to mention that the updated version of your tool didn't work for me, it just gave me "ERROR: no Resolution bytes found." The old one at the wiki did the trick though! I'm using XP sp3 if that helps you somehow. Thanks again!
  • Theorell.. Could you provide the link for the other prefs.prop patch that you found on "wiki".
    I downloaded the latest version from another thread and it worked fine. Had a ToMI sesh this morning worked fine, went to play in my lunch break and it doesnt work. Tried the patch again and all I get it the "ERROR: no resolution bytes found"
  • BB22;157478 said:
    Theorell.. Could you provide the link for the other prefs.prop patch that you found on "wiki".
    I believe he meant this one:

    Either way, it is the older version of the tool.
  • Per the long documention at the widescreen gaming forum, you need to play the game and change the resolution once before the tool will patch the file.

    This is why I had a brain fart and started this thread. Even though I changed the resolution, I did not play the game. And the patcher said the file was invalid. Considering how I made the program, you think I would know better, but....

    I'll try the new version again this weekend to see if there is a problem with it, but I did use it a few times to try 640x480; 800x600; and 1176x664 on TOMI 1.1 and W&G demo.
  • Yeah like Taller Ghost Walt said the one that worked for me is v1.0 located at the widescreengamingforum wiki. Derrick: I did try setting the resolution to pretty much every option available ingame. I also checked the prefs.prop files last update time to be sure that the game updated it after changing the res. Still got that error msg. No idea why 1.1 works for some people but not others though, maybe you could keep both files up in case others run into the same problem?
  • I just updated the program to 1.1a. Hopefully that fixes the bug. Please try it and let me know.
  • Works great now, thanks!
This discussion has been closed.