User Avatar Image

S&M 1/2 and TMI Not Opening

posted by Turophile on - last edited - Viewed by 596 users
I just though it might be easiest to separate it, as others can run S&M 1, and I cannot.

My desktop is a Q9550, 8GB of RAM, GTX280, with a Xonar D2X.

Now, I get nothing if I _enable_ GX mode (Direct3D sound/EAX), but if I disable it I get the Sam and Max launchers. Either way I get nothing from TMI.

I suspect my issue is tied to my sound card in some way, and I have tried:
  • updating my sound card drivers;
  • updating my graphics card drivers;
  • updating my motherboard/chipset drivers;
  • updating direct X ('the same or equivalent' version is already installed);
  • clean booting.
My operating system is Windows Vista Ultimate x64.

From dxdiag

Operating System: Windows Vista™ Ultimate (6.0, Build 6002) Service Pack 2 (6002.lh_sp2rtm.090410-1830)
Card name: NVIDIA GeForce GTX 280
Monitor: SyncMaster 225MD/225MS/2280HD(Digital)
Driver Name: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um
Driver Version: 8.15.0011.8618 (English)
DDraw Status: Enabled
D3D Status: Enabled
AGP Status: Enabled
Description: Speakers (ASUS Xonar D2X Audio Device)
Default Sound Playback: Yes
Default Voice Playback: Yes
Driver Name: cmudaxp.sys
Driver Version: 5.12.0001.0008 (English)
Driver Provider: ASUSTeK
HW Accel Level: Basic
Cap Flags: 0xF1F
Min/Max Sample Rate: 100, 200000


If there's anything else required to debug it, just ask. And if it's not appropriate to have opened a new thread feel free to close/delete/merge as required.

Visual Studio 2008 sometimes opens to debug, claiming access is denied to something (memory address).

My laptop can run Sam & Max Season 1 (that's all I've tested), but it heats up pretty badly from that, so it's one hour hits of that.

Edit: My laptop loads TMI (both loader and onwards), but the lag (7400 Mobile 'TurboCache' :() makes it unplayable.

Edit #2: S&M 104 (Lincoln Must Die) does not work on my desktop with either the Steam version (it worked before!) or the direct download. I'm not sure if that was pre-sound card / old computer though.

My guess is it's related to Direct3D sound processes failing, but that shouldn't have any affect on the launcher... when the DVDs arrive I'll confirm that.
14 Comments - Linear Discussion: Classic Style
  • There's a chance the launcher isn't starting due to securom reasons. Do you have any sort of debugging software running when trying to boot it up? Even something as simple as Process Explorer can freak it out sometimes (updating PE actually fixes the problem). That or CD cloning tools like Daemon Tools. I too am confused at how the soundcard plays into this, but I'll poke around
  • Well, the Xonar series have software emulated EAX 5.0, which has been known to cause issues with various applications. I'm guessing S&M/TMI don't have EAX 5.0, so it shouldn't be that, but it still freaks Direct3D out from time to time.

    I shall run through Programs & Features and see what, if anything, has an attached debugger and remove it (even just temporarily).

    EDIT: Well, I have Visual Studio Professional on both systems (laptop and desktop), and Adobe Acrobat 9 Pro on both, so I would assume it's not their services. I'll remove Crystal Reports and various other add-ons from the desktop and see where that gets me. Trying a clean boot with a few things removed.
  • Okay, running nothing but Microsoft Services (and even some of them have been disabled) and I'm still seeing the same symptom from both products.
  • Thought this could be fun to see how far things got.

    I ran procexp.exe (Process Explorer) and tried to launch S&M. Reliably, I got the nice error from SecuROM letting me know I shouldn't be doing that, and a handy URL. Without Process Explorer I get the launcher, then the GameTap logo, then the TellTale logo, then it flashes away into nothingness.

    TOMI didn't make a sound, didn't throw any errors, it just disappeared, as usual.

    I was given advice that WinMM.DLL errors could be caused by the Xonar. So I rolled the drivers back to the version specified (which don't have the bug). I am presently running them, and running as an administrator (Right-click > Run As Administrator) I still see the same things.

    I cracked open ProcExp.exe to watch TOMI properly, and noticed it disappeared when RarExtLoader.exe went red, and so did TOMI's launcher, then both went AWOL.

    Not sure how this helps, but it's not a SecuROM issue.

    The installer is fine, it installs on my laptop (again, unplayable conditions, but it's enough proof it can open!).
  • Do you know why rarextloader.exe was running in the first place? Was it something we called?
  • Will;161599 said:
    Do you know why rarextloader.exe was running in the first place? Was it something we called?
    To my knowledge it belonged to WinRAR, so I removed that and it makes no difference. I've since re-installed it and the coincidence has vanished.

    The only other applications appearing at the time are the virus scanner (MS Essentials - because betas are fun!), and the Search Indexer. They both seem to kick into gear. If I disable both, nothing happens, Monkey just cranks up the CPU and RAM usage and disappears.

    EDIT: Indexer probably just appears out of nowhere for no reason, so it's not really something I'm worried about. As I can disable the A/V it shouldn't be either.

    Sam & Max Series 1 games are the same, except that it shows the launcher and two screens before vanishing.

    EDIT: Sam & Max Series 2 games don't show anything past the launcher, they just flash a white box and disappear. Bone ("out from boneville") also shows the launcher, but then does the white box flicker and disappears.
  • I'll add to the mystery. I put the DVD in the drive and it fails to launch.

    It installed, the launcher happily appears, but no dice with launching.

    I think I might have to format to resolve this, which is a fairly drastic step, but given I can back up the entire drive fairly easily I may get around to it.

    I'll give it some time, as I've resolved some lag on my laptop to play S&M, but it still leaves Monkey Island unplayable, sadly :(
  • I would just like to officially state that I hate computers. One last thing to check, do you have any tablets or other weird controller interfaces installed?
  • User Avatar Image
    DjNDB Moderator
    Will;163824 said:
    I would just like to officially state that I hate computers.
    Me too. I only study Computer Science so i can destroy "The System" from the inside :D
  • Will;163824 said:
    I would just like to officially state that I hate computers. One last thing to check, do you have any tablets or other weird controller interfaces installed?
    I'm hearing that Will, and no, sadly, I don't.

    I might queue this box up for a format at the end of this year (once all of Monkey is out and the DVD is sitting here too).

    It's probably fate (or that weird voodoo lady's children) telling me not to fail my final semester of university...

    I'll give something one last shot and report back shortly.

    EDIT: No dice. Tried putting in a different sound card, and removing all traces of the good one, nothing. Something else is causing this :(

    Good news... my laptop sort of plays it with a custom boot option (read: safe mode with networking, then running a batch to enable half a dozen services and dropping to Quality 1 (that is the lowest right, otherwise I've been lagging on the lowest...).
This discussion has been closed.