User Avatar Image

ToMI + Crossover Mac: no keyboard => no savin', no quittin'

posted by pygy on - last edited - Viewed by 1.8K users
Hi, I managed to install and properly run and play ToMI on my MacBook Pro in Crossover by following these instructions with this modification.

Briefly: install IE6 in a Win98 bottle, then make that bottle a WinXP bottle and install ToMI in it.


Now, the problem is that, in game, the keyboard is unresponsive, which makes it impossible to access the main menu to either save or quit. I have to rely on autosave and to hard reboot the computer to exit the game (ctrl-alt-esc doesn't work). The mouse-only controls (in my case trackpad-only) are also impractical, but it's not really important.



I have another, unrelated problem with the fullscreen resolution (1440x900). The game is actually displayed with a frame on all sides except at the left. When the cursor reaches the frames, the cross cursor of the game remains inside the graphic "window", and a standard arrow cursor appears in the frame. Then the clicks are not registered anymore, hence I have to aim precisely at the end of the graphics area to open the inventory. If the keyboard worked, I could use the "I" shortcut to open it, but it doesn't work at the moment, making this another annoyance.
12 Comments - Linear Discussion: Classic Style
  • Core Duo 2.16 GHz with 2GB of RAM
    ATI Radeon X1600 with 256MB
    Mac OX X 10.4.11
    Crossover 7.2.2
  • I'll try to update Crossover and report back.
    Thanks for you help.
  • Still no luck. I was actually using Crossover Desktop 7.1 (or is it "Crossover Office"?)

    I tried both Crossover Games 7.2.2 and Corssover Desktop 8.0.0.

    With the first, I get the behaviour already described above. With the second, the launcher looks perfect (cool!) but I cant activate the game, and, when I launch the demo, there are no graphics, just a white screen (with a black border at the top where you can see the OS X cursor if you move it up there). I can still hear the music, after a delay corresponding to the logo display, so I guess the game is running, with no graphics...

    I found a way to exit without rebooting: Cmd+Alt+Esc, but I still can't save.
  • Try setting the bottle tho show the desktop in a window. That´s what I did, and it solved the keyboard/white screen issues.
  • I'll try, thanks :-)
  • when i tried tomi in crossover games, i found that the keyboard worked when the bottle was set to win2000, but not if it was set to xp or vista. might be worth a go?
  • Enabling the desktop did it for me (both for input and white screen).

    I'll try the Win2k solution too.

    Thank you all for the help
  • Hey pygy, where did you enable those options. Have been searching through all option windows of CrossOver Games, but can't seem to find it.
  • Configure -> Manage bottles, select the bottle where you've installed ToMi, select Control Panel, then winecfg. In winecfg, select Graphics, and enter a size for the virtual desktop. Remember to enable "Show virtual desktop".
  • I'm having the exact same experience as pygy. Once I enabled virtual desktop, it cleared the keyboard problem and the 8.0 white screen.

    Now, is there any way to enable virtual desktop AND get full-screen mode? I'd like to run fullscreen AND be able to use a keyboard =)
This discussion has been closed.