Missing a "D3DX9_41.dll" or similar file? Read me!

edited August 2009 in Game Support
Some of you may be getting a message like the one below while launching a Telltale game:


If so, then you need to run the DirectX Updater again:

DirectX Web Updater
- Computer must be on the Internet when running this update.


DirectX Off-line Updater
- Computer does not need to be on the Internet to run this update, but it's a 93+mb file.

They both do the same thing. The first one requires the Internet to download files at install time, the other one has all the files you need up front.

Details to what's happening:

Telltale games require more recent DirectX updates than what's originally included in Windows XP, Vista, and 7. To combat this, I include the DirectX Web updater with the game's install program. Microsoft doesn't include DirectX as apart of Windows Update, I have to resort to using the web installer at install time.

However, this requires the computer to be on the Internet at installation time. Otherwise it's an extra 100MB per episode. So if the Internet isn't there, then DirectX isn't updated. I wish there was an easier way about this!

For reference, the season DVDs do and will continue to have the off-line version of the DirectX updater on the DVD.


  • edited June 2009
    I see. Where do I put these new directx files so that Muzzled! will make use of them? I downloaded the web updater, but it refuses to run... So I downloaded the files. Where do I extract them? Maybe I should reboot.

    EDIT: Ok, I figgered it out. Among the files you download in the End-User pack, extract the contents of the zip file named "Mar2009_d3dx9_41_x86" to "C:\Program Files (x86)\Telltale Games\Wallace and Gromits Grand Adventures\Muzzled".

    The game started up without a hiccup after that.
  • edited June 2009
    Thanks so much man... I was freakin out because I couldn't solve the problem
  • SegSeg
    edited June 2009
    FauxVyse wrote: »
    I see. Where do I put these new directx files so that Muzzled! will make use of them? I downloaded the web updater, but it refuses to run... So I downloaded the files. Where do I extract them? Maybe I should reboot.

    That concerns me as the installer is doing a little more than just putting in files to System32. What operating system are you running on?
  • edited June 2009
    I told the Muzzled installation program to update DirectX but still got this error, and had to follow the update in this thread anyway.

    Is it because I don't have Windows Genuine Advantage installed on my computer and had to validate my copy through the download on the WebUpdate page for DirectX?

    Unfortunately, when I try to install the DirectX upgrade, it complains that a "CAB file is not reliable" (translated from Swedish). Anyone else have this problem?
  • edited June 2009
    BTW, one suggestion is to offer two download links, where one includes the DirectX files. For those of us who don't pay per byte downloaded. :)
  • edited July 2009
    it seems that the directx updater that comes with the game download gets blocked by firewall. At least for me it did. I disabled my firewall and ran the installer again. It worked just fine.
  • edited July 2009
    Updated DirectX but, thanks to TTG tech Shaun, found the issue when I ran DXDiag and got Display Tab 1: No problems found. Direct3D functionality not available. You should verify that the driver is a final version from the hardware manufacturer.

    Sooooooooo....I'm still shipwrecked with my antique laptop.:eek:
  • edited July 2009
    FYI I just downloaded the file direct http://www.dll-files.com/dllindex/dll-files.shtml?d3dx9_41 and stuck it right in my download folder and now it works fine.
  • edited July 2009
    I solved a similiar problem with Tales of Monkey Island by updating Windows XP to Service Pack 2 version.
  • edited July 2009
    Wouldn't it make more sense to include the D3DX_41.dll in the installer in the first place? As far as I know these updates are both self-contained and freely redistributable, so why ask users to download and install a 100 MB copy of DirectX if all they need is a 4 MB (probably about 2MB compressed) DLL?
  • WillWill Banned
    edited July 2009
    Generally speaking, if someone doesn't have that one file, it's almost always a good idea to update the rest of your DirectX. Probably a good half of the problems people have are related to an out of date or corrupted DX installation. And the web installer only updates files that are out of date, so the actual amount of data downloaded is probably closer to 10mb than it is to 100
  • edited August 2009
    sorry but i my laptop still have problem after all these actions,I've download manually the missing .dll but still i don't know where to copy it!I have windows Vista premium and geforce 9600 gt and 3gb memory.i am a little dissapointed about that problems,we talk about an adventure not for the latest FPS-CPU killer to have so serious issues!
  • edited August 2009
    ..........but with a few tweaks now it's all ok and i am happy about that cause i love Telltales,yeahhhhhhhhh
  • SegSeg
    edited August 2009
    Do not manually find and copy over individual DLLs. Please use the DirectX installers as outlined in the first post.

    The DirectX installer not only obtains and places the DLLs in the right place, but cleaned up any problems with DirectX. In addition, other games/software use different version to run their games. Using the installer will make every available version work.
  • edited August 2009
    One thing worth mentioning: I did have the same problem on Windows7 RC1/64. However, the error message got buried under a generic error message ("needs to close"). So if that happens to you on Windows7, it could still be a DirectX error and you should still consider reinstalling DirectX.
  • Hi there!

    Just downloaded them and went to the extraction of files. When I tried opening the app, it went through! :)

    I hope this would help!


    Good luck! :P

  • edited December 2014

    An internal system error occurred. For whatever reason, I rebooted my PC and tried again, and it installed properly this time.

This discussion has been closed.