User Avatar Image

Feast Part Four

posted by wkjezz on - last edited - Viewed by 944 users
Ugg 100% Stumped to say the least...
28 Comments - Linear Discussion: Classic Style
  • Maybe you are using the wrong exit? Look closely on the map; from purple you must take the path leading DOWN to get to green.
  • I'm a bit stuck with the first idol, it's in unbreakable glass and I can't open it. In Chapter 1 there was this breaking device but I can't get it from that guy again. Could anyone give me a hint on that please? I've been at it for a while now but just running in circles :)
  • You don´t have to do anything with the idols in this chapter, just fold the map so that you can get to the red one (see my pic) and then refold to get to the question mark.
  • Ah ok thanks :) I thought I had to rotate the idols to match the facial expressions on the map like in the last chapter :) That really had me stuck for like 2 hours.
  • Hi I also have this same issue. The map is folded correctly showing the path south from purple that bends up to green. In order to reach green I need to follow the path south from the purple Idol. I am at the purple idol, the map shows the path to green, the ground shook when I folded the map as required at the jungle entrance, however when I go south nothing happens. He doesn't walk back and say there is no path, he just goes offscreen and that's it. I can walk northwards back into view. Very frustrating!

    Just for clarity I am trying to go purple idol to green idol and I have both top and bottom map folds folding inwards so the map looks like this <###>

    Am I just doing something completely stupid?
    Creepwood;217468 said:
    I am Stuck @ the purple Idol when I try to go to green

    I've folded exactly like 108 Stars did in picture 1.
    But when I walk down, nothing happends

    What am I doing wrong ?
  • ive done wot u said but going down from purple doesn't do anything you just keep walking so your out of screen but never move on to the next screen
    108 Stars;217988 said:
    Maybe you are using the wrong exit? Look closely on the map; from purple you must take the path leading DOWN to get to green.
  • darkqwerty;220529 said:

    i have uploaded a picture of the map as i have it at present as shown in video walkthrough and as discribed by many is there still sumut iam doing wrong its very annoying now
    Hmm.. What can I say? It seems that you've been doing everything right. It worked for me the way you've done it.

    I trust that you have tried folding/refolding at the spot where you're at (with the appropriate rumbling effects) and that you have tried approaching the bottom exit from different angles. Not that it should be necessary, but still...

    Worst case, it seems you may have to resort to reinstalling the game.
  • Have you tried exitting the jungle and then re-entering and trying again?
Add Comment