User Avatar Image


posted by ToddD on - last edited - Viewed by 1.2K users
So I'm at the final battle with LeChuck but didn't get the keys on the first try. Now at the part where you can lift the broken door but nothing is happening, don't know how to get LeChuck to beat me up again...
23 Comments - Linear Discussion: Classic Style
  • what's the solution to this...bug?
    I've finished the game already but replaying it I end up at the same point with the same problem: after ripping the sail and telling Elaine to light the cannon, I cannot get Guybrush to get onto the see-saw, instead he's just making that joke. Next thing you know LeChuck's punching him to the crow's nest again. :(
  • I'll try again, and thanks either way Falanca.
  • I did, and I must have "used up my time" when I first tried because it worked a treat the second time. Thanks again for helping everybody out :)
  • I was wondering if I did something accidentally to make it work, so I replayed the scene but I solved it by doing the exact same thing. Well, goodie, have fun with the ending.

    Pshaw, it's nothing 8D
Add Comment