User Avatar Image

Can't seem to activate games from public WiFi areas

posted by machtrtl on - last edited - Viewed by 1.7K users
I'm in Italy at the airport, and I was looking forward to 6 hours of telltale games on my flight back to the states. I downloaded Ep 2 of Monkey Island, and when i try to play it, I can't activate the game. The little activation box won't accept my username/password, and I get an Unlock Unsuccessful message, followed by the following helpful info:

Error: Something went wrong.
"Sorry, we ran into problems.

No unlock code was entered. Please enter your unlock code in the unlock code field and try again.

If you need more help, contact us at [email][/email] and include this error code: UNLOCK EMPTY

I'm thinking that you just aren't connecting to your servers for some reason. Even though I'm having no trouble surfing the web, checking email, going to the Telltale games forum, looking at my account, downloading my game, etc., the little activation box just can't connect.

I have emailed the support address, but I'm thinking that given time differences, the likelihood of our getting this fixed before I take off is pretty slim. Since I have nothing else to do while I wait for the plane (I'm obviously not playing a game), I figured a plea/rant on the forum site to make unlocking a legitimately purchased game easier would help fill the time. (for example, just automatically emailing me the unlock code with my order receipt would save a lot of trouble, and there is precedent for doing it this way--in fact, I think that's how most games do it.).

On the off chance that there are Telltale games support employees in Europe, or insomniac ones in the US, I'm posting this.

7 Comments - Linear Discussion: Classic Style
  • User Avatar Image
    DjNDB Moderator
    Is it the Mac Version?
    There is an issue if Ping is blocked on the network, which might be the case in public WiFi networks.
  • Well, I'm back in the USA, and at yet another Airport hotspot-- this time it's T-Mobile, and still I can't get on.

    I did try pinging, and sure enough, I can't (though I can ping and a bunch of other web sites, though not all).

    From my limited sample, I would say that this is the rule for public WiFi areas, not the exception. I'm about to try to connect to the boingo hotspot and see if that works; I will also try tethering my mobile phone, but it's on t-mobile as well so I'm not hopeful.
  • Now on boingo, no ping, no activation....

    Now on t-mobile tethered from cell phone, no ping, no activation...

    I'm thinking maybe ping's not the way to go for this thing.
  • Oooh, just tried a Sprint cellular wireless card in the laptop.... And it doesn't work with that either.
  • Final post: I'm home now, and it is still not activating. Now I'm wondering what is up with my computer. I can still ping most web sites, but not At this point, I'm just going to wait for the manual code to be sent by tech support and hope for the best. I'd be interested to know if any other mac users are having this problem.
  • Hi,
    I have a MAC and am experiencing the same problems. I have been emailing someone at support back and forth but so far no luck. I was sent an unlock code but it didn't work... I looked into "ping" but i don't really get it.... Can anyone explain what you have to do? I went into my Firewall settings. I just have the inbuilt one and i allowed the application Monkey Island and then on my Firefox settings i allowed .....i don't know what to do now..

    I just want to play!

    I thought downloading a bought game would be really great and convenient...
This discussion has been closed.