User Avatar Image

SBCG4AP SecuROM on Linux issue

posted by Sloshy45 on - last edited - Viewed by 419 users
I decided to buy SBCG4AP (Strong Bad) on DVD instead of a download (actually, my parents got it for my birthday). I installed the game with the latest WINE perfectly, but when I try running one of the games, it says it cannot detect my CD drive. Should I have gone with a download? Is there a patch to remove "the virus known as SecuROM", or to let the game work on Linux correctly? Thank you in advance!

PS: I bought Sam and Max season 1 as a download, and the installers and games work perfectly with the latest WINE; SBCG4AP shouldn't be much different. If it wasn't for SecuROM I'd be playing by now :\.
4 Comments - Linear Discussion: Classic Style
  • User Avatar Image
    Macfly77 Moderator
    Not sure about your Securom problem, but on another note, where did your parents buy the game from?
    If it's from Telltale's website (I believe the only place to get a new copy), you should still be able to download the episodes from your (or your parents'?) My Telltale page.
  • I believe my mom got it from I can always play the games on my Windows partition, but I'm looking to get rid of it as soon as possible. At the moment, the only thing I need that partition for is Civilization IV and Portal.

    Getting back on topic, is there a way to get my SBCG4AP season available for download instead? Maybe I could prove it with my serial number, Amazon order, md5sum of the ISO (I like backing things up if possible), or something?
  • Nevermind, I got the issue somewhat fixed by mounting the disc drive and/or ISO as a CD drive via winecfg. I think my problems are pretty much solved for now. Thanks for at least having a forum :D!
  • User Avatar Image
    Macfly77 Moderator
    Sorry about my lack of helpfulness (not sure how I spaced out that the game had had a retail release other than just on Telltale's website... let's just chalk it up to tiredness...) and glad you found a workaround (even if it's not ideal) ;)
    There might still be a better solution... Have you tried e-mailing Telltale support at [email][/email]?
This discussion has been closed.