The Sam & Max Ep.303 Game Killing glitch, Steam version. Post contains spoilers.

edited December 2010 in Game Support
Hi there,
Reporting a major glitch in the Steam Version of Sam & Max Episode 303 - They Stole Max's Brain which completely kills the game and leaves you unable to continue.

The glitch occurs in the Museum,
after using the Brain Screw on Sammun-Mak and the cutscene that follows, Sam is made to fight Skunkape.
After the start of the fight, Skunkape taunts Sam and the player should then have the action selector ring appear.
However, a glitch occurs where the action ring does NOT come up.
After Skunkape taunts Sam, it cuts straight through to Sam growling and attacking Skunkape, then being hit back.
The game then continuously loops back to:

Skunkape taunting Sam,
Sam AUTOMATICALLY growling and attacking, no action ring appears at all.
being hit back,
Skunkape taunt,
Sam growls and attacks,
gets hit back
Skunkape taunts... etc etc

This loops continues until I End Task in task manager, or the game crashes.

This means that I cannot complete the game.
Please refer to this thread on the Steam users forums:

Myself and a few others have done a mini investigation to try and find possible solutions :p including:

* Never using Max's teleportation ability during Act 3 to teleport to the Museum by leaving the DeSoto there.
* Using the saved game of another steam user who COULD complete the game without the glitch occurring.
* Running Steam in offline mode.
* Deleting all local game files and saved games from Steam, and re-downloading/re-installing the game.

all of which have still resulted in having the glitch and being left unable to continue.

Speaking to other Steam users who did and didn't have the glitch and were able to continue the game, I've found the following to have no relation to the glitch:

CPU manufacturer. Both AMD and Intel users have experienced the problem.
Graphics card manufacturer. Both ATI and Nvidia users experienced the glitch.
32bit or 64 bit OS. Myself and another user are both using 32-bit OS, however I had the glitch and they didn't.
Platform. Different users playing on PC have either had the glitch or not.

However there have been some possible links.

Multi-Core Processors. A user running a single core processor did NOT have the glitch, however on my multi-core PC I DID have the glitch.
OS Version. User running Windows XP had NO glitch, my Windows 7 machine DID.

Going by resposnses on the Telltale Games forums, the glitch seems to only be happening with the Steam version. It may be something wrong with the code you sent to Valve to put on Steam, hence me posting this on here :confused:

Apologies for the lengthy post, But I thought I should give you as much detail as possible about what we've already discovered to help you get to the root of the problem faster :)

Many Thanks :D


  • edited June 2010
    thanks for posting this.
    in-meinem-turm- here:winslow:
  • edited June 2010
    der_ketzer wrote: »
    thanks for posting this.
    in-meinem-turm- here:winslow:

    Cool :)
    If there's any details I missed don't hesitate to add.
  • edited June 2010
    FunkyCris wrote: »
    Cool :)
    If there's any details I missed don't hesitate to add.

    The problem is that I cannot add much this time since I don't have the problem this time.
  • PsyPsy
    edited June 2010
    I've tossed this bug to a few different people. We never experienced it in testing and it seems incredibly sporadic but since it's a critical bug we have some people looking into it. Hopefully we'll come up with something soon, sorry about the issues :(
  • edited June 2010
    It looks like the processor cores ARE the problem. I just opened the game and used Task Manager to set it's affinity to 1 core, and the scene doesn't loop anymore!
  • edited June 2010
    Several reports in the steam forum now that setting the CPU affinity to 1 solves the problem.
  • edited June 2010
    Awesome, thanks for that info :D

    Reminds me of that old bug that Grim Fandango used to have where if you had a processor that was faster than 400MHz (epic speed :p) then the lift would move too quickly for you to get it stuck with the forklift truck.
  • WillWill Banned
    edited June 2010
    I'll look into seeing if we can figure out what caused this thing in the first place. Weird and unfortunate!
  • edited June 2010
    I dont have the steam version I have a tell tale commercial one and I have this glitch
  • edited June 2010
    have you tried the fix mentioned in this thead?
    Did it work?
    You also seem to be the first with the TTG-version that has this problem. Strange.
  • WillWill Banned
    edited June 2010
    We've been on the horn with Steam about it and we are doing a joint effort track this sucker down. It's something pretty deep in the engine so it may be a little tricky.
  • edited July 2010
    yea set affinity in task manager works glitch was pissin me off
  • edited August 2010
    Is anyone still seeing this issue? If so, can they post up a DxDiag file? It might help debug the problem and get it fixed for future game releases.
  • I had this issue. It was fixed by setting the processor affinity.

    Windows XP SP3, Mac Book Pro, late 2007 version.
  • edited December 2010
    -- This post only applies to the steam versions of season 3 --

    I can confirm setting processor affinity fixes the infinite action loop.

    I can also confirm the crash on startup is due to multi-monitor configurations, and copying a fixed .props configuration file (located in your my documents folder) once you've managed to get the game to start causes all the other games to work properly.

    This issue affects all the season 3 games for sure, i have not tested season 1 or 2 (still downloading).

    Steps to fix crash on startup (in multi-monitor systems). disable monitor 2, start game. alt-enter to force windowed mode. reenable second monitor. set games resolution to your native display resolution, and then reenable fullscreen. worked like a charm.

    as a note: having to set affinity and disabling secondary monitors is a serious engine bug, and i can only hope a fix will be back-patched into the previous episodes.

    All the relevant information i can think of.

    OS: Windows 7 (64bit)
    CPU: AMD Athlon x2 6400+ (3.2Ghz)
    Ram: OCZ DDR2-800 4GB Dual Channel kit
    Video: NVidia 9800 GTX+
    Sound: Creative X-FI powering Razor Carcarious Headphones
    Monitors: Dual Hanns.G/Hannstar 24" LCD Monitors [1680x1050@60hz]
    Controller: Joytech XBox 360 Controller (Wired) for Console/PC

    UAC: Enabled
    Anti-virus: Microsoft Security Essentials

    attached to this post is my dxdiag report (64bit)
This discussion has been closed.