User Avatar Image

Weird audio issue on Vista

posted by TheSpyder on - last edited - Viewed by 2.6K users
I just bought the episodes from Steam (didn't realise they were available outside the USA before now :(), and I'm having a few issues with Vista.

The biggest problem for me is the sound - I have a 5.1 speaker setup and while music comes through my front speakers ok, all sound effects and speech comes through my rear left speaker only. It's really disconcerting :)

I tried changing my sound settings so Vista thinks I only have 2 speakers plugged in, and it comes through correctly in what sounds like stereo - so while it makes life harder when I want to play it's by no means a deal breaker.

My sound card is an onboard Realtek AC97 audio, from a motherboard that is a little over 3 years old (MSI K8N Neo2 Platinum).

I'm also seeing the access violation errors in the _drm.exe files as mentioned in other threads. DEP is off except for windows services. The really weird part is that every second or third load it comes up and plays without any problems (except the audio as I mentioned above). This happens for all 6 episodes - I've managed to load each of them at least once.

I noticed in other threads about this issue that there is an unreleased version that may fix the access violation - I'd be happy to try it and see if it helps the audio problem (assuming I can even use it with the steam editions).
15 Comments - Linear Discussion: Classic Style
  • I wouldn't really call the audio issue "worked out" but it'll do for now :D

    I'm running an amd 3500+, 2gb ram, vista ultimate. Video card is an ATI x1950 pro (the AGP model), 256mb vram. If there's anything else you need to know I'd be happy to help out, I'm a software engineer myself so I know how tough it can be to solve crashing issues :)
  • I just finished the first episode, which means that whatever is causing the crashes it's during startup (before the game goes fullscreen). No problems once the game has actually loaded.
  • Could you try deleting the prefs.prop file out of the episode's game data folder before launching? This should force the game to start up in a window and at its lowest graphics settings. If the crash is being caused by something before it goes into full screen, it's possible that deleting prefs.prop would resolve it. (Once the game has started, you can go into the Options menu and fiddle with the graphics settings.)
  • Unfortunately I'm at work now (It's Monday morning in Australia ;)) so I won't get a chance to try that until tonight.

    The game never started windowed for me however - it went 800x600 full screen the first time I loaded it. Maybe steam shipped it with a props file and that's causing problems?

    BTW I doubt most steam users would know where to look for the props file. For reference, it's in:
    Steam\steamapps\common\sam and max episode
  • The game starts at 800x600 and full screen by default, so that's normal. Once you delete the prefs.prop file it should start in windowed mode.

    Thanks for the heads up on the location of that file, too. :) Let us know if deleting it makes any difference for you.
  • I got home this afternoon and none of them would crash :(

    I hibernate my PC rather than shutdown so I rebooted - and then they started crashing again, hehe. Deleting the prop file so they would load windowed didn't fix it (I tried all 6 episodes).
  • None of them would crash, or none of them would launch?

    I hadn't heard back from Valve so I wrote back to them yesterday. As soon as we know something more, I'll post here.
  • none of them would crash :eek:

    it all seems fairly stable now, but much like last time I bet if I rebooted they would start crashing again.

    It's certainly not affecting my ability to play the games at all... I'm well into the third episode already :D
  • Valve has set up a test version of the games that is slightly different. They want you to try it out and see if that resolves the problem you're having.

    I'll send you a PM with the details. Please let us know how it goes.
  • responded via PM.
This discussion has been closed.