(Puzzle Agent) Game gives black screen after ending and (presumably) before credits

edited September 2010 in Game Support
I have doubts if I should post this here or in the "help" discussions, so, sorry if I got it wrong.

As the thread title says, I have been encountering a weird technical problem with Puzzle Agent.

Everything worked fine until the very end, besides the fact that, when quitting the game, the "yes" and "no" squares were without text and you could only see their colour and the bug that several people reported about the sleigh disappearing if you returned to the factory after a certain event almost at the end.

But, when I get to the actual ending, at a certain point
after you are back in your office and Tether's boss tells him he should not worry about Isaac's disappearance, since the local police will take care of it and his mission to reopen the factory was accomplished. Then Tethers looks dubious and the scene fades to black.

Then credits should probably be rolling but the screen goes black, while the computer seems to be loading, but nothing happens and the only button which works is the space (in fact the word "paused" comes up on the black screen and goes away if you press space again). I've tried waiting but it was pointless and in the end I had to use ctrl alt del to get out of the game. I tried loading it again and I was just before the last puzzle, I solved it again and the same thing happened. I know it is not a major problem, but I may be missing a part of the ending, plus I wanted to signal this for future reference.

Thank you!


  • edited July 2010
    Maybe that was the credits, but the font had a glitch of some sort, which would make sence because as you said, when quiting the game you saw the yes/no squares without text.

    Although, I am kind of instantaniously wrong about my theory because I had the same problem with the yes/no squares and the credits apeared just fine.

    Was the Puzzle agent theme playing in the background during the black screen? If so that would proove my theory.
  • edited July 2010
    Thanks for your reply!

    I tried playing it again and no, there are no sounds, just a black screen and the buzzing of the computer when it is trying to load something.

    Plus I could see all the inscriptions perfectly, the only things that did not appear were that "yes" and "no". Ah, and another problem I had forgotten about was that sometimes the scroll list to select an already solved puzzle did not appear and you could only see the first ones (this happened several times quite randomly and then solved by itself).

    I have an ATI Radeon card, I could give specs here but I do not know how much it would help...
  • edited July 2010
    Hmmm that is odd, I am really sure what's going on. Although, it shouldn't really matter very much, because you are not missing out on much of the game apart from free play mode, which alows you to replay all of the puzzles and play any of the optional puzzles you missed.

    I'm sorry, but thats the limit to how much I can help, I'd recomend posting this in Game Support. Then we can wait for a telltale employee to read this then they can find out what the problem is and fix the glitch.
  • edited July 2010
    Does updating your graphics drivers help any?
  • edited July 2010
    @ Elzbenz: is there a way to move this thread to the other forum? Otherwise I'll just open another one, but I wouldn't want to create double threads for no reason. Yes, you are right, I am not missing much, but I posted this especially since nobody reported a problem like mine and I think it would be good feedback for the guys at Telltale to know most if not all glitches/bugs, so they can try to solve them or male improvements for future releases. That said I have played all the Sam&Max games and TOMI and I never encountered any game-stopping bug or problem.

    @ DaVince, I have a 2005 Vaio Laptop, I have already tried updating the drivers, but ATI site redirects me on Vaio site and Vaio claims that my model is not supported anymore, so no more updated drivers. That said it runs most recent adventure games perfectly... Actually it ran even this one, it's just that it apparently did not want for it to end :D Or was trying to leave me with an even bigger suspance and more question than the real finale...

    Anyway, thanks again!
  • edited August 2010
    I am also having the problems described here.

    So is there any news on a fix?
  • edited September 2010
    I'm also having this issue.
  • edited September 2010
    Me too.

    Update: I uninstalled Puzzle Agent, wiped off the installer, downloaded it again and reinstalled it. Works fine now; very odd. To those with this problem, you're not missing anything from the story - it goes straight to the credits from the point where it all blacked out. However, as has already been mentioned, you do get the opportunity to play any puzzles you missed (and replay ones you already did) after the credits finish. If you do decide to uninstall and reinstall, be sure to make a copy of your saved game first (My Documents\Telltale Games\Puzzle Agent) - it's deleted by the uninstall process without any warning.

    By the way, I am still getting a R6034 Visual C++ Runtime Library error every time I try to start the game from the adventure bundle software and it then doesn't load. A second click on "play" and it loads without a problem. Annoying, but not a major problem.
This discussion has been closed.