User Avatar Image

How I screwed up Culture Shock

posted by Zoinker on - last edited - Viewed by 507 users
I recently bought Sam and Max season 1 and, wanting to be clever, decided to activate the Demo of Culture Shock I had downloaded but never bought using the code I got for the entire season instead of downloading it again. It worked and I finished the episode in one sitting while downloading the rest of the series. For some reason, I then decided to reinstall Culture Shock using the download I got from the Season purchase but that's where I ran into a problem. Whenever I start the episode, I get the following error:
The security key for this program currently stored on your system does not appear to be valid for this version of the program. Select Yes to enter a new key, or No to revert to the default setting (if any).
I can still play the game by clicking no and then clicking "I've already purchased this" thingy and typing in my order number, but once I turn on the computer after shutting it down the error reappears.

This problem only appears with episode one, which is the only one I've reinstalled, not to mention with two different installers. I would appreciate some help, even if the whole thing is my own damn fault. Anyway, thanks in advance and keep up the good work!
6 Comments - Linear Discussion: Classic Style
  • Have you uninstalled the demo version? If not, try that. If so, try uninstalling all existing versions of Culture Shock from your system and then redownloading it from the store.
    None of that works? Best wait for Emily (or someone who has a better idea than me)!
  • You should never download the demo of a game after you bought it or it could screw up the full verison of that game if its stored under the same name.
  • Guybrush: I tried all that, but it still persist. What's worse, Texas Holdem is behaving in pretty much the same way now (I activated it through the Demo).
  • User Avatar Image
    Jake Telltale Alumni
    Write into [email]support@telltalegames.com[/email] with basically what you wrote in this thread, along with your order number, or the email address you used when making your purchase. Someone should be able to help you out! Sorry for the wackiness.
  • What operating system are you using? If it's XP, do you have the game in compatibility mode? That could cause this.

    If you're using Vista, that's the reason, because these games both have activation issues with Vista.

    Either post here with more info about your system or write in to support, and we'll help get you up and running.
  • You're right, I am using Windows Vista, and I'm going to do what you suggested in the separate thread you made about the issue. Thanks a ton! :D
This discussion has been closed.