User Avatar Image

Downloaded Episode 2, But I cant play it

posted by MagnaCarta80 on - last edited - Viewed by 875 users
The browser shows the background for episode one with no links/play button to start the second episode.
27 Comments - Linear Discussion: Classic Style
  • Not working for me either. Tried everything in this thread. :(
  • What I mean is that I can't go on the back to the future game at all. It quits every time! Please figure something out. I have no idea what to do. When I payed $24 for this it worked, but now it's not letting me get on! Please,please,please help me. :(
  • I have the same problem but I'm not on a mac. I'm on Windows Vista Ultimate. Running as administrator etc. didn't solve the problem.
  • Allright, found a fix for Windows at least.

    You have to go to Episode 1's launcher in Program Files (not just the shortcut, actual launcher) and then "Run as Admin". Then I had to relog and it activated ep. 2.

    Seriously stupid system, though.
  • Exactly the same problem here, on a macbook. Anyone from Telltale feels like giving us an answer??
  • I am having the same exact problem. Is a fix coming?
  • I know whats wrong with it! It WONT play! I mean seriously why CANT it play for the mac players!?! What should I do!?! Do I re-download the game?Tell meee! Im VERY frustrated!!! >:(
  • the problem for me is that the first ICMP packet to always fails:

    edgar:~ mschrag$ ping
    PING ( 56 data bytes
    Request timeout for icmp_seq 0
    64 bytes from icmp_seq=1 ttl=55 time=98.499 ms

    during the startup process of the launcher, it tries to ping but with a "ping -c 1" which returns with 100% packet loss, making you appear to be offline = launch screen doesn't work.

    if you're daring, this fixed it for me (BACKUP YOUR Mac_Game EXECUTABLE FIRST!)

    perl -pi -e 's#ping -c 1#ping -c 2#' /Applications/

    this will change the "ping -c 1" into a "ping -c 2" which then made the launcher realize i was online.

    hopefully this will help other folks.

  • will the slowdowns be fixed?
  • Oh yeah, finally some free time to continue the game from where I was, but the game won't play for me either. :(
This discussion has been closed.