User Avatar Image

I Downloaded It, But Can't Play (Episode 1)

posted by monstro567 on - last edited - Viewed by 1K users
Hey I just downloaded my copy of Back to the Future: The Game Episode 1, but when I launch it I get this window with all the episodes listed on it. I clicked on Episode 1 and then clicked play yet it won't launch the game. Someone please help me.

P.S. If it helps I run on Windows 7.
17 Comments - Linear Discussion: Classic Style
  • Just downloaded first episode for free but couldn't play it either.
    My file was called "BackToTheFuture101 DRM 15.15" or something like that so i just deleted that last part so my file is just called "BackToTheFuture101" now and it worked. I have Mac OS X
  • Run as administrator doesn't work for me, i get the same problem. I bought the whole series and have downloaded ep 1 and 2 and neither will play.

    Windows 7 64-bits. Admin rights.
    And the ctrl+shift+- , ctrl+shift++ doesn't work either..
    This makes me sad..

    UPDATE:
    After a few hours of troubleshooting i figured out that the game didn't like AirfoilInject3.dll, a file associated with Airfoil. So i uninstalled Airfoil and now i can play! The game looks great!
  • DMC-82;455927 said:
    Just downloaded first episode for free but couldn't play it either.
    My file was called "BackToTheFuture101 DRM 15.15" or something like that so i just deleted that last part so my file is just called "BackToTheFuture101" now and it worked. I have Mac OS X
    Yep this worked for me too!
  • Doesn't work for me on OS X 10.6.6 either. Renamed the file, and it now lets me click play, but all I get is audio and then it crashes. Any ideas?
  • User Avatar Image
    Macfly77 Moderator
    deKay;456996 said:
    Doesn't work for me on OS X 10.6.6 either. Renamed the file, and it now lets me click play, but all I get is audio and then it crashes. Any ideas?
    When you hear the audio, switch to windowed mode by pressing command-f.
    Then, try lowering the graphics quality settings.
  • DMC-82;455927 said:
    Just downloaded first episode for free but couldn't play it either.
    My file was called "BackToTheFuture101 DRM 15.15" or something like that so i just deleted that last part so my file is just called "BackToTheFuture101" now and it worked. I have Mac OS X
    This worked for me too, after a couple of days frustration.
    Weird bug, Telltale, just weird.
  • Macfly77;457084 said:
    When you hear the audio, switch to windowed mode by pressing command-f.
    Then, try lowering the graphics quality settings.
    This worked! Thanks.

    On my MacBook I lowered the settings to the minimum but it's jerky. At least it works though. On my iMac I could actually set it to maximum and it now works fine.

    Surely letting you set the graphics options *before* loading the game would be the best idea?
  • User Avatar Image
    Macfly77 Moderator
    deKay;457331 said:
    Surely letting you set the graphics options *before* loading the game would be the best idea?
    You would think so, wouldn't you? ;)
  • i'm running on snow leopard 10.6.6 or whatever, still can't get it to work. i tried renaming the file, re-installing, and do the windowed screen thing. nothing. also tried running in terminal, didn't work either.

    i want my free game to work!! any help?:(
  • DMC-82;455927 said:
    Just downloaded first episode for free but couldn't play it either.
    My file was called "BackToTheFuture101 DRM 15.15" or something like that so i just deleted that last part so my file is just called "BackToTheFuture101" now and it worked. I have Mac OS X
    Cheers, this fixed it for me. :cool:
This discussion has been closed.