User Avatar Image

The game won’t play

posted by akcarver on - last edited - Viewed by 1.5K users
I just got my copy of BTTF Episode 1, and was able to dezip the file without any problem, but when I launch the game and the splash screen comes up, I can’t get past it. I press enter and nothing happens. I have a MacMini from late 2009 with a 2.53 GHz Intel Core 2 Duo and 4 GB of RAM. What’s going on here?
20 Comments - Linear Discussion: Classic Style
  • Same here. I downloaded the free version of Episode 1 a few days ago, then just now tried to play it for a second time and nothing. Choose Episode One on the menu, nada. Click the "Play" button, zilch. :(
  • same here...i played it when i first got it. Now i've gone back to play episode 1 again and clicked the play button but nothing pops up!
  • Telltale go back in time and fix it!!!!!
  • I had this problem on Windows 7. Right-clicking and choosing 'Run as administrator' solved it.
  • Finally!!!!!!!!!!!!!! I am able to play!!!!!!!!!!!! I re downloaded the game yesterday and didnt work but then today it works!!!!!
  • ...So was this fixed? because I'm having the same problem. re-installing the game lets me play it, but as soon as I quit, re-open the game again and hit the 'play' button nothing happens. It has been a while so I was hoping maybe there was a solution already about this.

    Also, while logging in with our username is ok, why do we have to do it every time we open the game? One would think after buying it we could play it on PCs that don't have an internet connection.
  • I have a PC and on episode 1, I click new game then answer the next question then it loads then it quits. On episode 2, it goes to where Doc is told to get out of the time machine with his hands up and you are about to play for the first time then it quits. Do you have any advice?






    BTW I have windows 7.
  • I am also having the same problem. This is ridiculous. If you reinstall the game it works fine. However, the instant you save and close downt he game it's back to square one with the "Play" button not working.

    I shouldn't have to run as this game as Admin each time even though that works.
  • Has anyone figured out a fix for this yet? I have a T-Mobile card and I can't download and reinstall the game every time i want to play it.
  • I wrote another possible solution in the middle of my message here:

    http://www.telltalegames.com/forums/showpost.php?p=464074&postcount=24

    However, it apparently doesn't work for everybody. You can give it a try.

    If you download and save the installation program once (instead of running it directly when downloading), you can re-install without the big download. Of course, you shouldn't have to....
This discussion has been closed.