User Avatar Image

Back to the Future - Can't click "Play"

posted by Capitalist on - last edited - Viewed by 5.6K users
I installed back to the future, after I log in however, the button marked "Play" doesn't launch the episode so I can't start it.
44 Comments - Linear Discussion: Classic Style
  • This is just plain stupid. This is my first game from this company..and while I need a better computer to be able to play it on, just trying to play it on the one I have was even more of a pain since I kept uninstalling it/installing it just to try it out.

    Does the company even post in the forums here? This is something that obviously needs to be fixed :eek:
  • I had the same problem in Win7 32-bit and came search here. The "Run as Administrator" fix worked for me, but it sure shouldn't require it. :/
  • Add my name to those annoyed by this. The Play button doesn't work as non-administrator on 64-bit Win 7. I only got the one free episode, so the orange button on the other episodes says "Buy Now", and it works when it says that! (I can click the button to open a browser that takes me to the place to buy them.) It just won't let me Play! If it weren't for this thread, I wouldn't even know that I had to run as Administrator to fix it.

    None of your other games requires Administrator privileges to play. This one shouldn't, either.

    EDIT: I found another solution, at least for Windows 7. XP Compatibility Mode. Go to the executable in Program Files\Telltale\Back to the Future The Game\Episode 1. Right click BackToTheFuture101.exe, select Properties. Choose the Compatibility tab. Check the box to run the program in Compatibility Mode, set the dropdown to Windows XP (Service Pack 3). Press OK. Now the Play button works.

    (I don't know if this has any other bad side effects. I only tested it as far as the opening screen.)
  • Same is happening to me. Running Win7 x64 and the game is not letting me play by clicking the play button.
  • Okay, I've tried uninstalling and reinstalling several times, including reinstalling as an administrator and it still doesn't work. And for me, the window that launches the game won't even load the launcher buttons. I'm using 64 bit Windows 7.
  • Did you guys try the XP Compatibility Mode trick? I stuck it in the middle of my last message, to make it harder to spot.
  • When I try the XP compatibility mode trick, some error message pops up saying it can't load the game and to make sure I'm trying to run it from the directory it's installed to, which I am.
  • Arrgghhh! I am a loyal TellTale supporter who has downloaded and played almost every game the company has produced without incident. Now all of a sudden with BTTF 2, I can't launch the game. I have downloaded it and run set-up three or four times now. The game does NOT create a desktop shortcut icon or show up in "All Programs," but it does appear under "Uninstall." I don't know much about computers, so none of the above gibberish about "Run as administrator" means anything to me. Anyone patient enough to explain what I should do here?
  • Have you tried looking in the folder it's installed to?
  • I have the same damn problem, im running Win7 x64. Cant click the effing play button. Surely they have made a fix by now? Really annoyed.
This discussion has been closed.