User Avatar Image

Back to the Future Mac

posted by jhaan on - last edited - Viewed by 227 users
Hello,

I have been having problems palying Back to the future ever since I purchased it. I downloaded episode 1 and was not able to play it, I was then instructed to turn of the internet as it probably blocked by a firewall and the "play" button therefore did not appear. This seem to happen with episode 2 and 3 as well, but when turning off the internet I am still not able to play it. Why could this be, and how can I fix it? Ive tried to contact telltale support for several months now without success

Please help me!
5 Comments - Linear Discussion: Classic Style
  • What are your system specs, jhaan? And what version of OSX are you running?
  • Mac OS X Version 10.6.6

    Processor: 2.26 GHz Intel Core 2 Duo
    Memory: 2GB 1067 MHz DDR3

    Im not too sure if this was the information you needed :)
    let me know if sth is missing
  • Hi!!

    Do you know what could be wrong??
  • Jhaan, I had your same problem, so i solved it in this way:

    after copying the game in Application folder, open the terminal and past in this string:

    for Episode 1: sudo /Applications/BackToTheFuture101.app/Contents/MacOS/Mac_Game

    for Episode 2: sudo /Applications/BackToTheFuture102.app/Contents/MacOS/Mac_Game

    for Episode 3: sudo /Applications/BackToTheFuture103.app/Contents/MacOS/Mac_Game

    After copying one of these string (depends on which Episode you want to play), press Enter button, then insert your password (of your computer account, not Telltale account) and that's it!

    I hope that it works for you too!
  • Thank you so much!!!
This discussion has been closed.