User Avatar Image

Very Disappointed!

posted by Kikstar92 on - last edited - Viewed by 781 users
I'd just like to say that so far I'm very disappointed with my purchase of the Jurassic Park game. Not the gameplay, but the game itself refuses to install on my mac. I installed it on my brothers pc and the game works but very poorly. Delays are frequent and the load procedure does not work properly. This is the first time I've bought something from Telltale Games and it has been nothing but trouble thus far and according to many other threads, I am not the only one. In fact, i think I'm part of the majority. I paid $50 for this game and not been able to play it at all so far. If anyone agrees with what I've said, please share cause the more complaints, the better!
20 Comments - Linear Discussion: Classic Style
  • it's a mac, problem solved.
  • Romeosierra616;560266 said:
    it's a mac, problem solved.
    beavermatic;560221 said:
    dude... it's a mac. What where you honestly expecting?
    Seriously you two, enough trolling. It's not funny, particularly when it's at the expense of someone having a problem.
  • I'm a Mac user (Snow Leopard) and it installed for me without having to do anything to the .dmg, but there is a known issue and a fix for the Mac installer on the support forum.
  • Actually MOST complaints have been hardware issues and not software.. Telltale games can not be responsible for what types of computers people use and they do provide minimum requirements so people should not be surprised when their computer is not up to it.
  • Same here, I simply opened the DMG and dragged it to the Applications folder and that was it. (Aside, will we see this game on the Mac App Store? Surely that would help them shift a ton of copies)

    From the sounds of it the downloads are possibly stopping early and a download manager would help.
  • beavermatic;560221 said:
    dude... it's a mac. What where you honestly expecting?
    Thanks for this constructive post. [/IRONY]
  • I don't mind the gibes directed at Macs guys, but if anyone can help me it would be greatly appreciated!! The current status of my download is that when i try to place it in 'applications' from the 'downloads' folder, the icon doesn't change which is what usually happens, something to do with 'unpackaging' or something. so then i try to open it normally and it says it doesn't recognise it. Then i tried opening with disk utility and tried 'converting' it there but that ended up with the same outcome...I'm open to ANY suggestions!
  • Kikstar92;560912 said:
    I don't mind the gibes directed at Macs guys, but if anyone can help me it would be greatly appreciated!! The current status of my download is that when i try to place it in 'applications' from the 'downloads' folder, the icon doesn't change which is what usually happens, something to do with 'unpackaging' or something. so then i try to open it normally and it says it doesn't recognise it. Then i tried opening with disk utility and tried 'converting' it there but that ended up with the same outcome...I'm open to ANY suggestions!
    It's midnight where I live, but I think I know what's wrong, now that i have
    more info. I'll try to replicate your problem in the morning and see if I can find a solution for you.

    It is likely to be a problem with the way your computer is unzipping the file.
  • divisionten;560925 said:
    It's midnight where I live, but I think I know what's wrong, now that i have
    more info. I'll try to replicate your problem in the morning and see if I can find a solution for you.

    It is likely to be a problem with the way your computer is unzipping the file.
    Thanks a lot, appreciate it!
  • All fixed!! thanks a lot anyways guys! Got help from the telltales support crew and the only problem was with the browser. I was using google chrome originally, changed to safari, worked perfectly!
Add Comment