User Avatar Image

Jurassic park: Says I'm offline, and other problems

posted by Barrymosaurus on - last edited - Viewed by 1K users
I have just bought and downloaded Jurassic park the game. I was really excited but now whenever I try to start playing It reads: You need to sign in to play, but you are offline', or something along those lines...
I should probably mention a few points that, if anyone was nice enough to help, should consider:

1. I live in the UK and use a UK Macbook
2. I have OS X snow leopard
3. It's kind of new, and I am great with technical Jargon (probably not good, that).
4. At first, this problem was non existent, but it did say my username and password was incorrect (and believe me, they were!)

Anyway, i tried replying on a similar post, but I wasn't sure whether my predicament was exactly the same or not, as I tried to doing what that forum suggested. Anyway, sorry if I'm spamming, but I am very desperate, and, this being my first tell tale game, my opinion on this company rests on how easy this problem is to fix...

Thank you to anyone who gives me a helping hand!
2 Comments - Linear Discussion: Classic Style
This discussion has been closed.