User Avatar Image

Jurassic Park Episode 2 Problem

posted by rodmanrc on - last edited - Viewed by 1.4K users
I have this game for X Box 360. On the second level, The Cavalry, the two guys are standing outside the visitor center and they can hear stuff going on. I try to see what's happening, but the game just stays in place (from the point of view of being inside the visitor center). All the directional cursors disappear and I can't move forward with the game. I have shut down the game and come back, but the same thing happens. Help would be greatly appreciated because I literally cannot place this game any further if the game doesn't work. Which would stink because I am enjoying it greatly so far.
20 Comments - Linear Discussion: Classic Style
  • Help, anyone? Any patches or anything? This can't be it. Surely, there has to be a trick of some kind.
  • All right, well, I guess it's time to chew somebody out, Telltale.

    First of all, your customer service absolutely stinks. The day of my problem, I called customer service and left a message. A voice mail said that someone wasn't available at the moment, but to leave a name and number, and someone would call me back as soon as possible. That was three darn days ago.

    Second of all, I registered on this forum and posted a message about my problem. I had done some research on the Internet beforehand, and I found out I was not the only one having this problem. Some people experienced it in the PC version, others the Steam version...mine was the X Box 360 version. So I figured enough people had complained about this bug that someone at Telltale was aware of it and, perhaps, working on a patch, or, at least, working in some regard to fix this problem. That was three darn days ago.

    Telltale, I love this game you have produced. It is obvious you folks adore Jurassic Park. I, too, love the series (especially the first movie), and I was beyond excited when I heard months ago that a game was coming out for it. So I waited...and waited...and finally came out, but I did not purchase it. I put it on my Christmas list, hoping that Santa Claus would deliver it for me. Turns out, I was a good boy this year and got exactly what I wanted.

    I popped the game in, and in no time, I was fully immersed in the world you guys recreated. I flew through the first-of-four chapters and couldn't wait to dig in on the second. And then in the second level of the second chapter, the game glitched, and I couldn't move forward.

    I quit, restarted...nothing.

    I changed the video settings...nothing.

    Heck, I even turned on the subtitles thinking that might re-glitch the game into moving forward again and...nothing.

    Okay, no biggie. I'll get a hold of customer service. you see where I'm going with this, guys?...wait for it...nothing. You guys are just as reliable as the product you published.

    I'm not asking for a darn patch right this second. I know you guys are busy enough as it is with customer complaints. But, for the love of all, I feel like I've been ignored. A simple, "We've heard your complaint, buddy, and we're working on it!" would have sufficed. But to go 72 hours with nothing, I feel like I got the shaft.

    This is the first product I've purchased from you, Telltale. I was enjoying it immensely. But if this is your level of customer service, ignorning people who inquire about your products when they don't work, then this will also be the last product I purchase from you.

    I was equally looking forward to purchasing the new Walking Dead title that is looming on the horizon. But I get the feeling you guys don't care.

    So I won't, either.
  • Hello,

    I understand your frustration and I apologize. I never received a call from you, though. It's possible you went to somebody else's voicemail and it wasn't forwarded to me. Our Contact Us page and my outgoing message both state that we're not able to provide technical support over the phone and the best thing to do is send an email to [email][/email] if you're having an issue of that nature.

    In regards to your issue, you may be stuck in conversation mode. I assume tapping both of the triggers on the gamepad doesn't help? If they don't, please try restarting that episode and see if that resolves the issue for you. I apologize for the inconvenience.

  • First of all, thank you for getting back with me. My regard for your company has improved now that I know my voice has been heard. That's all I really wanted to begin with. To know that somebody at Telltale had heard my complaints and acknowleged them.

    As for where I'm stuck in the game, I have tried every trick in the book. I restarted many times. I have turned on -- and turned off -- subtitles. I have reset the video and audio settings. Anything to get the game to move forward again.

    I bought my console in 2008, so I thought maybe it was because my console was outdated. But this is the only game I've ever had this problem with. I even performed the X Box 360 update the other day through a friend, and even the new settings the updated provided did not jar the game loose.

    Any ideas you have would be greatly appreciated. I have really enjoyed the world Telltale has recreated, and I am eager to press forward with the game.
  • Hi,

    You're restarting Episode 2 from the beginning, correct?

    The only other thing I can think of is maybe the disc is dirty and it's preventing data from loading in that specific spot. Can you make sure there's no smudges or fingerprints on the disc itself, please?

  • Yes, I am restarting Episode 2 from when the mercenary guys come flying into the park.

    The part where I get stuck is where two of the guys are standing outside the visitor center. They can both hear something going on inside. Then the point-of-view switches to being inside the visitor center...and the game freezes. The background music does a loop...and then it continues to loop. I can back out of this point-of-view and repeat the dialogue the bigger, tattooed guy says, but when it goes back to the point-of-view of being inside the visitor center, I can't do anything. There are no directional arrows, no icons indicating buttons for me to push...nothing. I literally cannot move forward.

    I checked the disk and it looks in pristine condition.
  • I'm like about to give up on Telltale games because JP isn't working on my Macbook either. I made it to Episode 2 and now it's "quitting unexpectedly." Changing the resolution and restarting doesn't help. I'm really frustrated.
  • Any ideas, Michael? Any ideas...anybody?
  • Sorry for the late reply. I've been looking into it, and it's not something that anybody else has reported, and there's not a ton of troubleshooting you can do with a console game. The only thing I can think to recommend now is clearing your system cache. The steps outlined on the Microsoft site below should walk you through it.
  • I followed the steps, cleaned out the system, and tried again. Same thing happened.

    Do you really think it could be my game disk? It doesn't have a scratch on it, but still...
This discussion has been closed.