User Avatar Image

Puzzle Agent (Mac) Crashes Upon Start

posted by BlackMcNulty on - last edited - Viewed by 467 users
I'd played about two hours of Puzzle Agent, quit out, and when I tried to open it again, it crashed. I've tried reopening it, deleting it and reinstalling, and everything else I could think of, but no matter what, it always crashes instantly upon launching. Anything I can do?
5 Comments - Linear Discussion: Classic Style
  • Are you receiving an error message when it crashes?
  • Yeah, here's some of the information that pops up:

    Process: Mac_Game [41497]
    Path: /Users/Library/Application Support/Steam/SteamApps/common/puzzle agent/Puzzle
    Identifier: com.telltalegames.Grickle101
    Version: (
    Code Type: X86 (Native)
    Parent Process: launchd [97]

    Date/Time: 2012-01-27 13:01:06.631 -0500
    OS Version: Mac OS X 10.6.8 (10K549)
    Report Version: 6

    Interval Since Last Report: 36858 sec
    Crashes Since Last Report: 1
    Per-App Interval Since Last Report: 7 sec
    Per-App Crashes Since Last Report: 1
    Anonymous UUID: 8FD11790-BAC5-436A-AA1C-EF18C321EAD5

    Exception Type: EXC_BAD_ACCESS (SIGBUS)
    Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000
    Crashed Thread: 0 MainThrd Dispatch queue:

    Thread 0 Crashed: MainThrd Dispatch queue:
    0 libSystem.B.dylib 0xffff07c7 __memcpy + 39
    1 com.telltalegames.Grickle101 0x0008ceb0 MetaStream::ReadData(char*, int) + 338
    2 com.telltalegames.Grickle101 0x0008d3bb MetaStream::serialize_TlsString(TlsString&) + 323
    3 com.telltalegames.Grickle101 0x00094c5a DebugString::MetaOperation_Serialize(void*, MetaClassDescription const*, MetaMemberDescription const*, void*) + 54
    4 com.telltalegames.Grickle101 0x00039f0b bool PerformMetaSerialize(MetaStream*, DebugString*) + 59
    5 com.telltalegames.Grickle101 0x00039cd6 Symbol::MetaOperation_Serialize(void*, MetaClassDescription const*, MetaMemberDescription const*, void*) + 76
  • Is there anything that I can do?
  • Are you using the Steam version? If so, please try verifying the integrity of the game cache within Steam. Also make sure you're running the latest version of Steam.

    Let me know if you're still having trouble with it after doing that.
  • I did that, and it said that all files were validated. And I made sure I had the latest update for Steam, which I did. Still crashes immediately.
This discussion has been closed.