User Avatar Image

Law & Order Legacies - downloads of episodes 6 & 7 keep failing.

posted by Macfly77 Moderator on - last edited - Viewed by 647 users
As the title says, the downloads of those two episodes keep failing after reaching 90% with the following error message: "Failed to download. If a problem persists, ensure a strong connection and restart the app or the device."
I'm using a Mac with OS X 10.7.3 and my connection is as strong as it was when I had no problem downloading the first five episodes.
I tried restarting the app (and even the computer, as it had been on for several days), but to no avail.
Any help would be appreciated (though this late on a Friday, I'm not very hopeful ;)).
Have a great weekend!
7 Comments - Linear Discussion: Classic Style
  • User Avatar Image
    Macfly77 Moderator
    Update: Still no luck with the Mac version. Tried a dozen more times over the last few days and the downloads still fail when 90% is reached.
    I installed the PC version with CrossOver and... the same thing happened the first time I tried installing the episodes.
    However, I re-tried a second time and the installation started at 27%, stopped when it reached 40% and the "Play" option for the episodes appeared in the menu (the exact same thing happened for episodes 6 and 7).
    I'm not sure what the issue is (and why, while they both appear to have the same problem, the PC and Mac versions act differently when I try a second installation) and was wondering if there was a possibility to update the (Mac) file that I can download from your website so that it includes all seven episodes.
    Thanks for your help!
  • Try deleting the prefs.prop file. I believe on a Mac it's located under /Library/Telltale Games/Law and Order - Legacies

    What's happening when you click Play for either of those episodes?
  • User Avatar Image
    Macfly77 Moderator
    Thank you, Michael!
    I'm going to try that right away and I'll keep you posted.
    FYI, on a Mac, the prefs.prop file for this game is located under /Documents/Telltale Games/Law and Order - Legacies
    As of now (before re-installation), there is no play button, just an install one.
    EDIT: Actually, that location appears to be that of the prefs.prop file for the CrossOver installation. Let me look some more.
    EDIT 2: OK, found it. It's under /Library/Application Support/Telltale Games/Law And Order
    Deleting now.
    EDIT 3: It didn't work, so I tried deleting the whole Law And Order directory, which, of course, deleted episodes 4 and 5. I tried reinstalling episode 4, but encountered the same problem, which probably means that something changed on my computer between the original installation of episode 4 a few months ago and this attempted installation.
  • For the record, I had the same problem as him. Only after trying again a couple of times (like, 5 or 6 times) I was able to download them in one go. I had the same problems with previous episodes, but the last two episodes were especially troublesome. The ingame downloads don't seem to work that well, at least on my end (even on strong connections). I guess all future Telltale games are going to work with ingame downloads (Jurassic Park and Law & Order seem to be hinting at that), so I hope they work better than in Law & Order. Otherwise I'd prefer being able to download these episodes from my internet browser, like with older titles.

    So yeah, I don't really have any advice to give other than to keep trying. I think the problem isn't so much your computer as the game though.
  • User Avatar Image
    Macfly77 Moderator
    Thanks Tjibbe. I tried deleting the only piece of software that had changed since I installed the episodes 4 and 5 (the sometimes praised, often reviled MacKeeper), but it made no difference...
    At least, after deleting and being unable to re-install episodes 4 and 5, I was able to recover them from a Time Machine backup.
  • Macfly, can you send me a PM with some details about your internet connection? What type of internet service you're using, whether you have a hardware filewall, wifi security type, etc...

    We've never been able to reproduce that issue internally, so any information is helpful.
  • User Avatar Image
    Macfly77 Moderator
    After sending Michael a PM, there was a new development.
    After I switched from Ethernet to Wi-Fi and de-activated OpenDNS (to be completely honest, I'm not quite sure why I use it), the download speed went up from 218/219 KB/s to the low 300 KB/s and I managed to download and install both episodes.
    I'm not sure if what helped was the increased download speed or the de-activation of OpenDNS (for all I know, it was an AT&T issue that was just resolved, since my download speed is still in the low 300KB/s after reconnecting the Ethernet cable and re-activating OpenDNS...), but it finally worked anyway.
    Thanks for your help, Michael!
This discussion has been closed.