User Avatar Image

Common JP Problems/Solutions

posted by TonsOfChocobo on - last edited - Viewed by 20K users
Let's consolidate solutions to common problems mentioned here so far. Add more fixes if you know of any.

-Frame Rate is lagging
In the graphics settings, lower the Shadow quality to Low and/or turn off the DoF option. This appears to be a graphics card issue on certain ATI cards.

-Mouse pointer randomly goes missing during Exploration sequences
Close the game and reopen it.

-Game goes back to main menu after completing a scenario
The game will only progress during a Load playthough. If you are playing using the Scenario option, the game will reset to the menu after completion, as was intended.

-Game won't start up again after exiting.
Open the Task Manager and look for the game in the Processes tab. Select it and hit End Process. Try starting game again.

-Certain Achievements not activating
Some achievements must be obtained through a Load playthrough and won't activate if playing on Scenario.
70 Comments - Linear Discussion: Classic Style
  • I have also face some of the problems from this list while playing the Jurassic park game and this information is really helpful to me for solving my problems. Thanks for sharing such a useful guidelines about JP game in this thread.
  • how to get cupon code for purches
  • Any updates about the mouse cursor disapearing problem? It's really a pain in the ass, many people encounter this problem and Telltale still had no fix for this.

    I'm kinda dissapointed in your costumer services. :(
  • So I bought the game off Steam in March, and it was working fine. When I try to play it today, it made it as far as the trademark screen and crashed. It kept doing it, too. It worked once when I rebooted my PC, but then did it again when I closed the game and tried to go back to it later. Can anyone tell me what's wrong with it?
  • Yoshi_D wrote: »
    I'm on a Mac running OS 10.7 and the game was running fine. I closed out, and now when I reopen the game, the screen goes black. The audio still plays and it I move the mouse I can hear it moving over the menu, but the screen stays black.

    Has this been figured out yet? I can't seem to find the solution anywhere.
  • Telltale needs to fix Jurassic Park the game. I to had problem with it that no one
    not even Telltale helped me with the game not going to the next Episode. i let the game
    rebuild the save and it fixed but no where in the forum was there a solution
  • Hi this is very frustrating. How about some correspondence here Telltale? I used to recommend your games because they are fun and customer service seemed to work. But ever since this Jurassic Park debacle, I am tempted to do the opposite.

    You have lost a customer; if you don't fix this game (or at the very least reply), I will spread word of this and you will lose more clients and potential clients.
  • I am having an odd issue. When I double-click the .exe the game starts up and the screen goes black (as it does with normal games) but then it just stays black. Occasionally on different times I try to play, it will do the black screen but then go back to the desktop by basically alt+tab'ing itself. I still have not been able to play yet and I'm getting frustrated. Please help with some solutions here!! :confused:
  • The "solution" offered to the problem of the disappearing mouse cursor is very unsatisfactory, and only acceptable as a temporary stop-gap until a patch fixes the issue. Re starting the game and playing though a scene again so you can reach the part where the cursor disappeared ruins the hard earned immersion, which is a shame because the game is otherwise fantastic.
Add Comment