User Avatar Image

Walking Dead Episode 2 Xbox Glitch

posted by BMM92 on - last edited - Viewed by 1.9K users
Hello, I was very excited to begin playing episode 2 this morning, so the first thing I did was boot up my xbox, download episode 2, and begin playing. It was fantastic, right up until I decided to frighten brenda, and now she backs up into the house, onto the stairs, but doesn't get attacked by a zombie, and instead she shoots me when I try to get to close, despite there being no talk or interaction option. As big of a fan of the walking dead I am, in addition to your wonderful game, I can't help but feel jipped if I have to replay everything up to that point only to make a different decision in order to avoid this glitch, if thats the case. Please look into it, and get back to me asap, I would love to have a fix or a solution so I may continue enjoying the mostly well built and fantastic second addition to your walking dead game. Thank you very much,
9 Comments - Linear Discussion: Classic Style
  • Hello,

    I'm having a similar issue. I replayed the previous chapter a number of different ways but still experienced the same out come. I am given two opportunities to talk Brenda down, then finally she shoots me. I can't see any other option or action to take

    I also noticed that I wasn't awarded achievements for the first two chapters.

    I really enjoyed the both parts of this game. It's a shame that this has left me with a somewhat sour experience, and the likelihood I'll have to wait a number of weeks until a patch is released is pretty disappointing.
  • Same issue here replayed a few chapters back with different decisions and the same outcome, please fix this glitch quickly! Can not get past Brenda at the steps, gives no option to talk.
  • Same fr me. I've tried every speech possibility and none work. So as far a I'm concerned im done trying.
  • Just got it to work. When she says stop moving dont move either stick. Wait a few secs if she doesn't shoot you then move the cursor over her.
  • I stood there for 5 minutes with no movement... nothing.

    Could it be that I'm on an Xbox Slim instead of a white Xbox?
  • BigPapaSpandex;626677 said:
    Same fr me. I've tried every speech possibility and none work. So as far a I'm concerned im done trying.

    I'm not given any speech options. After Lee opens the screen door Brenda takes a single step back to ascend the stairs a bit. From there, I receive no dialogue options.

    No matter how slowly I creep forward with massive pauses in between steps, I never receive a dialogue option.

    Eventually you move up so close to her she shoots you without any option appearing on the screen.

    Well, you are given a continue option when the game tells you that you're DEAD.

    EDIT: I was able to evoke one dialogue option by letting go of my thumbsticks when she first pointed her gun at me. I thought this would work the next time she pointed her gun at me, but no luck. I swear I am NOT touching any sticks/buttons/triggers/etc on the controller once she points the gun at me.

    I need to tap tap tappity the left thumbstick to inch forward, but there is absolutely nothing I can do to get past this part of the game.
  • Hey, I have a problem with the game. When i bought it, i couldnt play it. It kept saying to purchase again when I have already purchased it. Please Help?
  • I had to try it 10+ times. I was on th point of giving up. tuned off my Xbox an came back 30 mins later. An it worked fine. So it appear to be a glitch with no certain fix.
  • I had the same issue . I have a ps3 and at that part of the game there where no dialog options tried it about 10 times . I reinstalled the game and the glitch went away. On the ps3 you can load from your last save with a reinstalled game . That was my fix . Hope it works for you guys.
This discussion has been closed.