User Avatar Image

Walking Dead Episode 2 Xbox (not working)

posted by crayonsinboxes on - last edited - Viewed by 3.8K users
I download the newest DLC for the walking dead episode 2.
now when i go into the game my save no longer comes up but says I have to start a new game, which I could live with even though my save still exists
I then went to episode 2 which says I have purchased it but continues to say get and bring up the download prompt. I have tried deleting and re downloading but I still cant play it at all
any words of wisdom?
32 Comments - Linear Discussion: Classic Style
  • User Avatar Image
    Kevin Telltale Staff
    Are you sure you're playing from the same profile that you played the first episode from?
  • Hi,

    This isn't something that popped up during the testing process, and I haven't been able to reproduce it. For any of you having issues accessing Episode 2, are you certain you have enough free space on your device to complete the download? Are you saving it to the hard drive or to a USB device?

  • Thanks for replying mike. I have enough space available, its the same account, same profile, same hdd and the same console. I have tried every possible way of deleting, downloading and every other trick others have suggested. Nothing helps. It simply says 'get' new episode altough it also says that its already purchased. And as i said in my previous post, i can now only start a new game. It doesnt load my save games. I checked the storage option on the xbox menu: i have episode one downloaded (listed as an arcade game), my save game and episode two(listed as dlc). Everything appears as it should in other words.

    I have never expierenced anything like this before on xbox live. Thank you again for looking into it. As it stands now, i've bought a game i cant play
  • Yes, I purchased both episodes on the same gamertag. I'm using the gamertag, while signed in. So, I should have both the console license and the profile license on the xbox I am using. I tried another xbox while signed into xbox live on my account that had purchased both pieces of content, redownloaded the episodes, and it worked fine. Unfortunately, MY xbox still isn't working with it.

    On my xbox, I'm using a 360 S that has about 60 gb of space remaining, and the content is saved to the hard drive rather than the installed memory unit or a USB device. I also have tried moving the save file to the memory unit, and then to the cloud storage, but the save still did not show up nor was episode 2 available to play (just "get") on the console that isn't working.
  • Yes same gamertag, and I'm saving it to my hard drive which has 90 space. As the others say it's acknowledging the purchase but keeps asking for a redownload.

    Thank you for your time Michael
  • Just in case this helps, I bought and downloaded the episodes onto the HD of the same console (250gig elite with about 30gig free space) and used the same gamertag for both.
  • Well, not exactly the same problem. Whenever I try to run episode 2, the game just crashes and I'm sent back to the XMB. I have plenty of memory space. All three of my saves are filled, if that matters. It's the same profile I bought it on, and installed it on.
  • I have been trying different things and i've found a temporary fix that works for me at least. Load the game, at the press start screen, sign out your profile, then after an 'ol you cant do that message, sign back in. In my case, the save game suddenly appeared and i could select it. I still had to choose get episode and download it, but thankfully that took only a few seconds seeing as i already have it on my hdd. Then i returned an played the episode!

    However: when i exited the game i had to do the first part of the process once more(sign out, then back in), but not the get episode part.

    This is of course not a great solution, and telltale is hopefully working on a fix. But i can now play it at least.

    Hope this works for the rest of you as well so that you can play it!

    Fingers crossed for a fix and a quick reply from telltale regarding this strange and unfortunate bug/glitch or whatever this is...
  • Still trying to nail down what might be causing this, because we haven't been able to reproduce it.

    What region are you all currently playing in? Is the account you used to purchase the game in the same region that you're currently playing in?
  • I'm playing and live in Ontario, Canada.
This discussion has been closed.