User Avatar Image

[WD] Can't Play EP2 on PlayStation [RESOLVED - restart the game]

posted by American398 on - last edited - Viewed by 12.9K users
Hey guys, i have downloaded Episode 2 from the playstation store and installed it. when i got to play it, it sends me back to the main ps3 screen, i have seen other players have this issue also, any fix?
527 Comments - Linear Discussion: Classic Style
  • I wish I only had to wait 3 hours for episode 3 like i did for episode 2 today -_____-
  • Holy mother of pearls, ok i bow b4 you tell tale games and beg for forgiveness, yea i was one of those super angry customer going off mad about the delay mad about the ps3 screw up but after playing it dear lord yes it was worth the wait! wow it is awesome i will not get any sleep because i just want to keep playing it and stare at it over and over, sorry i will not whine again i will be patient as long as the other episodes be as amazing as this 2 has been you will not hear another wipmer from me! im def gonna check out your other games now and again i beg for forgiveness and thank you am gonna have a great weekend!!!
  • MINE STILL DOESN'T WORK. I just downloaded it today and i can't get into episode 2!!!

    It says its installed but when i press X, nothing happens.
  • Alan Johnson;628275 said:
    Hey guys! Question for all affected as we attempt to narrow down the cause:

    What method did you use to obtain the episode? Season pass or individual episode purchase?
    well i havent got affected but i know you want the ones that did get affected to answer but i will be getting it individual Saturday so ill be able to let you know tomorrow
  • Episode 2 is still not working for me. I purchased and installed it. I started the game (and restarted), hit "Play". It shows Episode 1, and I have the options "Play" and "Back". I hit R1 to go to Episode 2 and only have the option "Back". Not sure what to do.
  • Nevermind, I got it. For some reason, I had to unlock Episode 1 again for some reason.
  • I was going to thank telltale for the game after playing through ep 2 twice, but I started a third game from the beginning and when I got to ep2 my first two saves were deleted. So thanks for that like the world thanks god for cancer. edit Actually all three of my saves were deleted, the episode 2 it loaded was some random ep1 outcome.
  • Not resolved. Not for me, anyway. I just downloaded it from the PSN an hour ago, installed the update and tried restarting it when it didn't load Episode 2, but got nothing. It only says "Installed" but it doesn't even give me the option to choose an episode.
  • Folks is anyone getting issues were its just showing as "coming soon" in the game menu and not even showing on the PS store to download episode 2?
  • Thanks Telltale for the quick response to this problem, I am sorry for the backlash you had to deal with from a lot of gamers. You are in a tough industry and deserve much more respect..thank you.
This discussion has been closed.