User Avatar Image

French girl need help for episode 2

posted by annamay on - last edited - Viewed by 453 users
Hi everyone,

I'm a french girl who have bad english to ask help (but promise, i do my best).

So, i buy TWD on Telltale store (pass season), i install and play episode 1, and since afternoon, i can download episode 2. It's failed until 80%, window appear and tell the connection is to slow. I have a 20M connection (on the paper), but in real 1M traffic.
I read some post on this forum, but i found lots of same problem, but no solutions.
Is anyone have answer ( with simple english word, i learn school english in longger time ago).

Thx.
8 Comments - Linear Discussion: Classic Style
  • Are you using steam ?
    Are you using a PC or MAC ?

    I know a little french and english, but i'll try french :p

    J'ai aussi regardez les forums, ils dit qui le server a trop de travail pour le moment.
    Try downloading again, if you need a post translated let me know :)
  • I'm having the same problem…I'm on a Mac.
  • Same problem! I loved episode one but I'm rapidly approaching the point of demanding my money back and saying the hell with it.
  • Red_leader;632726 said:
    Are you using steam ?
    Are you using a PC or MAC ?

    I know a little french and english, but i'll try french :p

    J'ai aussi regardez les forums, ils dit que le server a trop de travail pour le moment.
    Try downloading again, if you need a post translated let me know :)
    Hi Red leather,

    Thx for answer.
    I don't use Steam (i got it on my PC, but i don't use it).
    i'm going to try again, and wait few days.

    You're French is good, congratulation.
    (cancel "qui" and use "que", "qui" is for person, "quoi" for things, and "que" for others like evenements for example).

    If don't works, i say it here.

    Bye.
  • It's ok. I got it.
    Thx everybody
  • annamay;633202 said:
    It's ok. I got it.
    Thx everybody
    ...so how did you solve it? Seems like there's a bunch of people with the same problem, me included.
  • I don't know, i try a lot of time and today it's ok. Iwait 1 hour, it's stop at 84% still 15 minutes and after it finish. Seems to be the server was surcharge ? Perhaps hours where your try to get it's important (like i'm in France, my day is your night).
    Sorry, i have not really answer.
  • Well for server load, you can try different hours.
    Like for me in Belgium day here is night in the US :)

    But for Mac users I think the problem is specific, try searching posts containing Mac.
Add Comment