User Avatar Image

glitch in epi 3, Can't See Jack!!!! Cant progress...

posted by CinnamonToast on - last edited - Viewed by 411 users
I had to join the forum after encountering a glitch on episode 3 that is preventing me from progressing... If anyone could help, I'd appreciate it!

so, spoiler (sorry, i don't know how to shade, i'll keep spoilers to a minimum):

I am on the train, in the cabin with Kenny. I've just finished confronting Chuck about what he said to Clem and then entered the cab with ken. Well, after i was done talking to Kenny, I've exited out the other door in the cabin, to the walkway where Ben is standing outside, and then is where the screen just goes haywire. The train disappears, and the view is of nothing but trees and the sky. There are no options, no where to go... just nothing. i cant exit out of that part except to go back in the cab with ken when i tap my left joystick. I've exhausted all dialogue with ken and i dont know what to do...

has anyone else had this problem, or is it just me? i'm playing on PS3 if that's important...

thanks in advance... i'm going to restart that section and hope it was a fluke
4 Comments - Linear Discussion: Classic Style
  • Happened to me to on the ps3. I reloaded my file and everything was okay from that point on. Hope it works for you too !
  • thanks for responding. I re-winded it a bit and played through that part again with no problems. Thanks!

    off to finish the eppy!
  • I just had this happen on the 360 version....what a crazy glitch, you barely have any room to see in the cab unles you talk to Kenny or try to grab the map....then when you're outside same thing the trees and rocks float in the air and you can't do nothing...hope they patch this.....I haven't tried rewinding yet but was curious if anyone else had this what an episode so far! would love to finish it but work comes early...thx for the info. thought I was the only one this happened to or it was a glitch for everyone in Episode 3 that they couldn't finish it
  • I had the same problem right after I cut Clems hair on the train.
    Hopefully this is really solved by just reloading the last save game. It was already very late yesterday, so I didn't try it yet...

    Edit: Oh by the way, I'm playing on Xbox.
This discussion has been closed.