User Avatar Image

Game breaking graphics glitch, PC version

posted by hurleybird on - last edited - Viewed by 242 users
When I try to start up episode 3, must of the textures fail to load. Entire models are invisible. It makes the game unplayable. After loading up episode 3 and returning to the menu it is also corrupted. Strange thing is episodes 1 and 2 play just fine, the issues only arise with episode 3.

Running a Radeon 7970, latest WHQL drivers, everything is set to use the game's settings in the control panle.
4 Comments - Linear Discussion: Classic Style
  • This happened for me when I installed the most recent drivers for the ATI Radeon HD series. The way I got around it was installing previous video card drivers that I knew had worked. So, if you just updated your graphics drivers I would try installing older ones and seeing if that works.
  • You are talking about TWD, right?
  • occono;662715 said:
    You are talking about TWD, right?
    Yes, I am... The lack of textures in my game looked like missing polygons on some figures and portions of background if that describes your problem. My problem only occurred after I updated to the current version of graphics drivers (updated like 3-4 weeks ago maybe?) like I said, so I reverted the drivers and it worked fine. I dunno if this will help you, but it is worth a try.

    Edit: It also occurred on the main menu and chapter selection portions. I believe the missing polygons were seethrough but I could be remembering wrong.
  • I was talking to the OP, he didn't specify the game.
This discussion has been closed.