User Avatar Image

Possible glitch in The Trial and Execution of Guybrush Threepwood

posted by JamesW on - last edited - Viewed by 606 users
During the Senses stage of the story there is a point where you need to fold a voodoo map in a particular way in order to open a path between a purple wind idol and a green wind idol. This opens up a path leading south from the purple wind idol to the green one (rumbling in the process). Unfortunately when you try to take the path nothing happens despite the map clearly showing the route is there. I know many people have successfully passed this stage of the game so if there is an error it clearly doesn't affect everyone. There are currently two other postings that mention this issue in the hints forum.
4 Comments - Linear Discussion: Classic Style
  • User Avatar Image
    HoboStew Telltale Staff
    Is there a chance that you could post a screen shot of the way the map is folded when this error occurs? There are a number of map states and it will help to know exactly what yours was in when this happened.
  • Thanks for replying. I had the map folded correctly, six sides showing a path leading south from purple leading to green.

    In the end I played on from an early saved game and this time around it worked straight away. Can't say what caused the problem, but if anyone else runs into this I'd recommend trying to playing through from a saved game from before they got the map.

    Thanks again
  • The same problem here. Can't take the path down by the purple idol. Does work with an older savegame. (noticed more bugs, but none which destroyed the gameplay)

    i've attached a savegame.
  • I know it's been a while since anyone has posted here but I'm going to give this a shot anyways ...

    I've got the map folded correctly and I'm at the green idol but no matter what I do I can't get Guybrush to take the 'up' path to the red idol.

    I've tried exiting the jungle ... refolding the map (I do hear the rumble of the jungle) ... you name it.

    Help! Thanks.

    PS: (A posting of someone's saved game right after would be a suitable solution if this is truly a bug).
This discussion has been closed.