[iOS] Walking Dead Episode 2 times out on install

edited October 2012 in Game Support

This has been a problem since episode 2 came out. The first time I downloaded it from within the app, it took 4 days before it would download fully.

Instead what happened was that after choosing "get" the download would randomly stop and a message would appear saying "Connection lost while downloading data. Please ensure you have a working internet connection and reattempt the download."

I had to reset my iPad which meant I had to reinstall episode one. I have spent the last two weeks trying to download episode two and I keep getting this message. This even occurred after the app apparently downloaded 118% of the data required according to the counter.

Now I have ruled out the iPad as being at fault, it successfully has downloaded 1.4GB movies from iTunes regularly and has not had the same error with any other service or in app download. I have ruled out my connection as I have been using the net on other devices on the same network at the same time as the iPad has been reporting this error.

What this appears to be is either a fault with the way the app itself manages large downloads or a problem with the connection at the server end where the episode is being downloaded from.

Is anything being done by TTG to address this fault? I have seen other posts floating around stating the same error from other users, so I know it is not an isolated case. I have deleted the app and reinstalled it to no avail. The problem persists and is becoming very frustrating now.

Is it possible that the change to iOS6 has made the in-app download even less reliable?


  • edited October 2012
    I am having same problem on a PC, it is not your IPAD. It won't download anything and immediately says conncection lost, check internet. Since I am on the internet posting this now, it is obviously a problem. I wouldn't have paid $25 for one episode! Any ideas for a fix? How do we contact someone for an answer?
  • edited October 2012
    Well it is getting to the point that I'm hesitant to keep trying to download at the moment until TTG have confirmed that the issue is resolved.

    There is definitely a problem and it really does need to be addressed.
  • edited October 2012
    Just wanted to say the recent patch appears to have fixed the problem. Ep2 downloaded. Good to know TTG had been working on the problem already. :)
This discussion has been closed.