User Avatar Image

Unable To Download Episode 4?

posted by SabreNation on - last edited - Viewed by 354 users
OK, I've been playing this series for a while now and have been looking forward to downloading and playing the latest episode all week.

I'm having one heck of a time getting to that point, though. I've run into a series of errors that I just can't seem to get around.

When I first loaded up The Walking Dead I got an error stating that my Telltale account does not have a license to play this game and asking me to buy it. I tried closing and restarting the app a couple times and got the same error. At that point I came to the Telltale website to ensure that The Walking Dead was still showing up under my purchases - yup, still there. So, I decided to try a quick reboot before I went contacting customer support.

The reboot appeared to work. I loaded up the game, got the "Connecting..." bar that I wasn't getting before and I was off to the main menu. Time to start the download so I click on the Download Content button. The menu loads up just fine but I am unable to download Episode 4. 1, 2, and 3 are still there downloaded but there is no link to download the new Episode. It just says "Coming Soon" next to it. I tried restarting the game again. Same issue. For the heck of it, I decided to reboot my computer again - it worked the first time, maybe I'll get lucky and it'll work again. No dice. I'm having the same issue.

Has anyone else had this problem or know a way around it? My real fear now is that I'm going to have to remove the program and reinstall it again. I'm dreading that because I had to do it when Episode 2 released and I somehow lost all of my save data in the process forcing me to restart. That wasn't so bad when I only had Episode 1 to replay. If I have to got through all 3 again - TWICE - I will be pretty upset...
5 Comments - Linear Discussion: Classic Style
This discussion has been closed.