User Avatar Image

Jurassic Park Episode 2 Problem

posted by rodmanrc on - last edited - Viewed by 1.4K users
I have this game for X Box 360. On the second level, The Cavalry, the two guys are standing outside the visitor center and they can hear stuff going on. I try to see what's happening, but the game just stays in place (from the point of view of being inside the visitor center). All the directional cursors disappear and I can't move forward with the game. I have shut down the game and come back, but the same thing happens. Help would be greatly appreciated because I literally cannot place this game any further if the game doesn't work. Which would stink because I am enjoying it greatly so far.
20 Comments - Linear Discussion: Classic Style
  • An issue with the disc itself is the only thing I can think of at this point. Are you able to exchange it for a new one at the store you purchased it from?
  • That's the one thing I can't do. This game was a Christmas present.
  • Just sent you a PM.
  • After many months of waiting, I just found out the library I work at has purchased a copy of this game for the X Box 360. Hopefully, this will answer the questions I have about this game.

    If this new disc works in my console, then I will know my own personal copy of this game is faulty. However, if the same thing happens, then it could quite possibly be that my 2008 console is "too old" to play this newer game. Once the game has been processed at the library, and I can give it a play, I will let you know what happens.
  • Well, it's official.

    I will not be able to play this game. The library cataloged our copy of the game, and I took it home to play it, hoping that whatever glitch plagued my copy would work with this second copy. But, alas, it was not to be. The exact same thing happened. It froze in the exact same spot as before, which means it must not be the disc; it must be how my console reacts to it.

    This is incredibly frustrating. I waited for months to play this game. And then I finally get it, and I can't play the majority of it. This is the first time since I bought my X Box 360 console in 2008 that this has happened, so I guess I should consider myself fortunate that it didn't happen sooner.

    I was also looking forward to playing "The Walking Dead" when it comes out...but if this is a Telltale trademark, a.k.a. games glitching, I probably won't.

    The parts I got to play were fantastic. I was really digging this game. It's just a bummer that I'll never get to find out how the rest of it was.
  • Any news on if a patch has been made available for this game? I'd really hate to have to purchase a new X Box 360 console or something just to play this game.
  • Youre not the only one having this issue. This game came out the day I deployed for 6 months. Im finally back and was enjoying the story of the game when bam it stops on me. Same exact spot and exactly the same way. Im also a huge fan, and am less then pleased with this. Worse part is the sessions are all locked. They should have just made a cheat to unlock all the episodes so we could just skip that problem area.
  • Im having the issue on the xbox elite.
  • I got mine to work. I changed the order of how I viewed stuff and it worked. The picture at the top when you are in the menu to change areas was black when mine glitched, after doing things in the order of the following video it changed to a picture of the vistor center and worked fine. Later,
  • Mike (or someone who can help), I hope you're still around...

    Episode 2 has a MAJOR glitch that prevents me from bypassing or completing a particular section. I've tried three times, but each time I become trapped in the dialogue with Oscar. There's no other dialogue options left, and I can't get out, can't switch screens, can't look around, can't do anything but click the same line over and over again (I took a short video to show, if you want to see it). I've tried to avoid talking to Oscar but it soon becomes clear that you can't "persuade" Dr. Sorkin until you talk to Oscar. This is very frustrating because there's no way to go past it, so I've paid for 4 episodes and will only be able to enjoy 1! That's unacceptable, don't you think? Is there a fix for this, a new download, a CD I can get and try again, is there SOMETHING?
This discussion has been closed.