User Avatar Image

the walking dead ios

posted by chiefzackery on - last edited - Viewed by 382 users
I want to buy the walking dead ios for my ipod touch 4g i loved the game on the 360 and i want to play it on my ipod but I here it dont work on some people ipod i got a 32gb ipod 4g will i be able to play it it says so on the game but it said made for iphone and ipad but it says compatible with ipod touch with ios 4.0 or above
4 Comments - Linear Discussion: Classic Style
  • User Avatar Image
    MattP Telltale Staff
    iPods are not a supported device for the Walking Dead.
  • MattP;709775 said:
    iPods are not a supported device for the Walking Dead.
    thank you for telling me i guess i will get an iphone soon
  • Well i decided to take the chance and guess what it works TellTale staff it works if you close out all your apps tell that to the people instead of telling them its not compatible hope to do buisness for episode 2-5 on ipod im buying all the episodes on 360 and Ipod
  • User Avatar Image
    MattP Telltale Staff
    iPods are not supported, nor recommended, due to differences in their system specifications. While an iPod may be able to run the game, various issues can be encountered during gameplay, especially extended gameplay, which is not an ideal experience. Therefore, we do not officially support the device.
This discussion has been closed.