User Avatar Image

Episode 3 Issues

posted by TheProfessah on - last edited - Viewed by 1.4K users
I get stuck after I've penciled the train directions. I press b again and again and I get nothing. So I quit and restart. I do all my chores to get to that point again and nothing. So I rewind and start again. Check list of go there and do that is done so I get back, hold my breath and it works. Next step. Switch 9. Absolutely nothing. I rewind and this time I make sure to examine it and try it before I manipulate any of the other train switches and still nothing. I know it's not easy to make a game. Especially one like this but it really feels like it's not worth it. I got one and two and loved em. I wanted to wait until the rest were out so I could play back to back. I guess I'm relieved that I didn't buy the next two just yet. I suppose this will go on the shelf for a while.
33 Comments - Linear Discussion: Classic Style
  • Guess I shoulda held my applause. After I cut Clementine's hair, the camera gets stuck outside of the train car. No cursors or anything. I'm able to jankily move the camera but not select anything. Rewinding again....

    EDIT:Showed Clem the map first and the game proceeded.
  • so i got the game on disc and i finish episode 1 and click to play episode 2 and it takes me back to the very start of episode 1 does anyone know how to fix this or if there will be a patch for this
  • Thanks guys. Even better that we don't have to wait for a patch :)
  • Thanks...worked like a charm!
  • I've been having these same issues. I literally kept rewinding and trying everything I could to be able to continue. I'm super happy you guys have figured out how to "fix" the issue by downloading episode 4 and 5... HOWEVER, I bought episode 1-3, have LOVED the storyline and gameplay, and now I don't have enough funds to get 4-5 until Friday and here I am, stuck in the middle of the crisis with Duck being bitten and wanting to get this train rolling. THIS.... SUCKS.... ASS!!!!!!! AAAAAHHHHHH!!!!!! :(

    ... but thanx for getting the issue "resolved" TellTale
  • Yes.this worked ,thanks.
  • it happens to me aswell, (the thing on the train you know the part where you cant turn on the engine nine or something) if you know how to solve the glitch or whatever, can you help me please? and thanks
    my english isnt the best as you might see...
  • AnnihilAnt;746684 said:
    After viewing the sketched notepad with train start up instructions on it you cannot move around the train or exit notepad view. It's says hit B to exit then flashes by for a second but still says hit B to exit. I was able to leave cab of train by selecting the train door and clicking. Once outside I cannot move and in the lower right corner it still says press B to exit.
    I have exactly the same issue as this

    I use the pencil to see the engine instructions and then i can click something once but that is it, it ehm does not allow me to move or select anything

    Ive tries reloading the save etc

    Im on xbox aswell (xbla version)

    EDIT: OK just saw the fix hopefully having to buy episodes 4 and 5 is a temporay fix :-)
  • Alright so I purchased episodes 4-5 to hopefully fix the ep.3 train glitch issue. Hopefully all goes well when I play tonight, I'll let you guys know. And if it doesn't, I won't... because i'll smash everything in my house to fucking pieces.. including this computer lol
  • We're golden!!! Just hope TellTale can get that REALLY fixed so that future gamers don't experience the same frustration!!!! :) And guys... thankyou for getting a temp solution to us die-hard fans so quickly!!!! Later!
    - DW
This discussion has been closed.