User Avatar Image

"Storage device lost"

posted by Luizao876 on - last edited - Viewed by 21.7K users
For some reason, everytime I play Episode 5, and when it is on loading, this pops on:

"The storage device was removed while saving or loading. The game will now exit to the title screen."

Then, when I restart to where I was, it never loads, it stays in a black screen and never loads.

Does Telltale or someone knows the solution for this?
157 Comments - Linear Discussion: Classic Style
  • User Avatar Image
    MattP Telltale Staff
    I apologize for the delayed response. We are still looking into this issue, but have been unable to replicate it. If you navigate to your settings tab on the dashboard and continue to storage devices, how much free space is listed for your HDD?
  • I apologise if I am coming across as short in my language but after struggling through lost saves and randomised choices, to be blocked from playing completely is frustration of the highest level.

    Currently there is 30.5gb of free space on my hard drive.

    As noted before another profile on my console is able to play without this error appearing.

    Thank you for the response.

    Edit: I deleted as much as I could from my hard drive and got it to 66.1gb of free space. The error still occurs.

    It is a shame but the game has essentially become unplayable for me.

    Seems I have only two choices. Start a new gamertag and hope the error does not also occur there or give up playing the game entirely.

    This "Storage Device Lost" error coming on the back of the previously mentioned ones is pushing me in the direction of the latter choice.
  • I don't expect this will be fixed before the new year, not with the holidays about to start. Hopefully though something will happen after that.
  • Well I decided to delete my save and try playing the game again. Hopefully I'll be able to get all the way through without an error popping up again.

    Got another title update for the game, so hopefully that will fix the issue.
  • Ok now I'm having this same problem too. And it's weird because I was able to finish this game 3 times without any problems, but when I tried to replay episodes 1 & 2 I got this error every time the game tried to save progress. I played episode 3 after that and I was able to finish the whole thing without any error. Then I tried episode 1 again and got this error. After that I deleted all my saves, signed in to live, got the latest patch and started episode 3 with random decisions and it worked just fine again. I deleted that save and started from beginning, I completed ep.1 without any issues and just when the Andy fight was about to start in episode 2 I got this error again.

    I have a 2-3 year old xbox360 with 120gb harddrive on it. The game is downloaded to that harddrive and i don't have anything else plugged in to my xbox. And there is 62,5 gb of free space left.

    I hope this message wasn't too boring to read, I just tried to be as informative as I can be :D
  • This is a great game but they seem incapable of fixing the errors it has, save reset and choice randomisation, and new ones keep popping up with the Storage Device Lost error and stuttering in the disc based version.

    As I said before I don't expect this will be fixed before the New Year but I hope it is soon after or Telltale could see this going from Game of the Year to Disappointment of the Year very quickly indeed.
  • Another bit of problem solving feedback. I replayed the game over the Christmas holiday on the gamertag that bought the episodes.

    I was able to play through and not once did I encounter the Storage Device Lost error.

    However on loading the game on other gamertags on the console, the error returned while playing.

    It seems that the error occurs, on my console at least, only if playing with a gamertag other than the one which purchased it.
  • voteDC;752651 said:
    It seems that the error occurs, on my console at least, only if playing with a gamertag other than the one which purchased it.
    I'm playing with the gamertag which purchased the game and I get this error all the time. Except when I play episode 3. :confused:
  • Well that's blown that idea then.

    I hope Telltale can get this sorted as I'd like to be able to play the game on my gamertag.
  • I think it would help our situation if everyone who has this problem would speak up instead of just lurking this thread and hoping this gets solved.

    Yes, I know you're out there! Speak up! :D
This discussion has been closed.