Let's Play... Simon the Sorcerer 3D

So I'm doing a run through that most infamous of bad adventure games, Simon the Sorcerer 3D. This is so I can do a Madisun's Arc review of it, and like all my video game reviews I'm playing through the whole thing and recording it so that I essentially have a complete video run of the game.

The thing is, doing this is long. And boring. And requires me to convert a LOT of videos from massive avi files (3.95GBs each) into smaller wmv ones that don't take up every bit of free space on my hard drive. And while the videos are converting, I can't actually play the game. Well, maybe I could, I dunno, but I don't really want to be converting video files AND recording footage from a game at the same time. I think my motherboard might melt.

So, during this down time, I figured I'd do something. Going back to the videos I've already converted to wmv files, I'm grabbing screenshots from them and I'm going to do a picture based storytelling exercise... thing.

So here we go!

Let's Play... Simon the Sorcerer 3D

The game opens up with a blatant rip-off from Star Wars. Because that was topical. (Actually, it was - the game came out around the same time The Phantom Menace was released on DVD. So this comment is probably a bit redundant and I should therefore probably stop talking.)

This text basically sums up the events of the first two games. I'll explain most of it as we go along, so I won't bother telling you exactly what it says here.

This is Runt. No, seriously. That's his name.


He's the 'apprentice' for the main villain of the series...


Oh no, it's just the titular SIMON THE SORCERER.

Oddly enough, you actually play as the bad guy in this series. It's a refreshing change from the norm, and makes the franchise a lot more interesting as a resul-

Oh, right. This isn't actually Simon. It's the warlock Sordid, who's spirit possessed Simon's body at the end of the previous game. Sorry. As you'll see later on, Simon's so vicious to people it's hard to tell the difference between him and the villain sometimes!

Sordid's been taking Simon's body on a funky little joy-ride, and while he's been away, Runt (god I feel so stupid every time I say that) has built him a nice new body to inhabit.

Which he promptly does.

Because let's be honest, if you had the chance to take on the form of a giant ED-209-like monster machine, you would to.

(How he'll ever get laid again is a question for the ages, but I guess we're not supposed to think about that.)

Runt (ugh) tells Sordid (actually, that sounds dirty as well. I think I'll need a shower after I'm done with this) about his plan for finding 'The Ancient One'.

He'll have to be more specific than that though, since there's around a thousand 'Ancient Ones', most of which aren't going to be particularly inclined to help a pair of Sordid Runts.

I mean, do they mean the guy who taught Doctor Strange?


The guy from Teenage Mutant Ninja Turtles?


This... THING from Star Wars?


Be a little more specific people, that's all I'm asking!

Then they both have a good laugh over a dirty joke. I think. I kinda zoned out there trying to decide which Ancient One they were talking about.

Uh, where were we?

Oh. Right. We're... somewhere else now. In the rain, apparently.
(You can't tell because it's just pictures, but there's no sound effects whatsoever here. It's really very weird seeing the rain but not actually hearing it. Odd disconnect.)

And we get a glorious ass shot (or at least it would be a glorious ass shot if the graphics weren't so awful) of some chick who must be absolutely freezing as she carries Simon's body to the top of a... wait.


No, seriously - How. Did. She. Do. That? You can't just brush something like that under the rug, game! It's a pretty big thing to skip over! Explain, dammit! EXPLAIN!



So the chick just leaves Simon's body at the top of the stairs as she does a dramatic pose in front of three old guys, which diminishes the effect somewhat, but I guess she takes what she can get.

Fortunately the old guys can make Simon's body float over to them, which just begs the question of why the hell they didn't do that in the first place instead of making Lara McNotCroft drag him all the way to the top of the pyramid.


And so they lower Simon's body into the pit of sharp pointy things coated with horribly nasty poison, and he was never heard from again.

Everyone toasts to a job well done and the game is over.


...I wish.


  • VainamoinenVainamoinen Moderator
    edited December 2012
    Why... are you doing this... to yourself?! :eek:

    It's like I decided to play "The Fall - Last Days of Gaya" again.
  • edited December 2012
    I thought about doing something like this too at some point. Davies does such a great job with his, though. Not sure I'd have the patience.

    I've always wondered about Simon 3D.
  • edited December 2012
    I called it:
    flesk wrote: »
    If it's graphics that makes the characters look like cardboard boxes it could be Simon the Sorcerer 3.

    Also, nice review. :) I love these kinds of Let's Plays. They're a lot easier for me to follow since they require less concentration and dedicated time than video reviews.
  • edited December 2012
    Aha! Bet you weren't expecting another part so soon! Well, I have to wait for a video of me collecting butterflies to convert, so here we are.

    ...yes, butterflies. Let's... let's not go there just yet. *shudder*

    Anyway. Where were we? Oh, right.
    That's not alcohol, sadly, that's Simon's soul. Which just raises another question of exactly how the good guys got hold of it, but whatever, let's just get this over with.

    They remove the seal and...

    ...start chanting. It's really rather dull. Next time I need to get off to sleep, I know what I'LL be listening to.

    Not quite sure why they've got the guard there. Maybe he was just tired of being left out. I dunno.

    Whatever the case, Simon's clearly had enough of it, as he legs it down the hole to try and get away from the constant droning noise that's suddenly started up. Because there's none of THAT in an ancient tomb, oh no.

    The old guys suddenly start waving their arms around, as if their pacemakers have just kicked in or something. Or maybe it's "the wave".


    ...yeah, doesn't quite work when there's only three of you, guys (I'm going to assume Amazonia Le HotPants isn't taking part).

    God clearly agrees, and sends bolts of... snowballs? Eh, whatever. They miss the old guys completely and smack Simon straight in the face. Trust me, he deserves far, far more than this.

    One of the old guys proclaims that "seven days and nights must pass" before Simon awakens. I'd complain, but since this cutscene's been dragging on for so long it already FEELS like a week's passed, I'll take that and run with it.

    The Pigtailed Princess here immediately makes herself out to be the most likeable character seen so far by claiming that they've wasted enough time on Simon already, that she's had enough the foul weather and that if the stories are true then Simon can make his own damn way out. I hereby proclaim this chick the best character in the entire game.

    This guy then says "oh dear". Clearly he knows something we don't.


    Time for a brilliant showcase of just how terrible the graphics are.



    ...and there's Simon. Still dead. Yay!


    And yes, those really are the textures they're going with. Hard to believe this came out the same year as Zelda: Wind Waker, isn't it?
    (Wind Waker came out in 2002 in Japan, so it bloody well counts, dammit!)

    Oh, and then he had to go open his mouth and start talking.

    Yes, one of the many, many, MANY benefits of only doing a Picture Playthrough of this is that you're spared the teeth-grinding, fingers-down-chalkboard, nails-in-eardrums pain of the primary voice actor. He's clearly a man in his late thirties desperately trying to sound like a teenage boy... and failing miserably.

    He's also trying to sound likeable, which is a frankly insulting thing for him to do given the actions Simon takes throughout the game. But we'll get to those. Oh yes we will.

    Oh, why are they focusing on that shot? It was bad enough the first time we saw it! Whatever. We've now established that Simon's trapped in this room.

    Gee, I wonder how we solve this 'puzzle'.

    "Now what" indeed, Simon. The Quit button's looking awfully tempting right about now, but that'd just be the easy way out.

    And so begins the first playable section. Christ, that only took 10 minutes. Reminds me of Daikatana, and the less I'm reminded of THAT bloated mess, the better.

    The first problem is with the controls. They're all over the place. We'll start with the movement controls, which are probably the least crippled. It's the arrow keys. Left and Right to turn...

    ...and Up and Down to move forwards and backwards. It's like driving a tank.

    Sort of.

    Let's head over to that blatantly obvious switch we saw earlier.

    ...after turning subtitles on, obviously. I'll be lowering the voices so I can avoid the terrible voicework from Simon, and you should be eternally grateful you don't have to listen to him at all.

    Right. Now, to the switch!

    ...now, if I could just remember which button I press to use stu-




    A fairy godmother. A Fairy. Fucking. Godmother.

    ...actually, you know what she reminds me of?


    Yes, I've played Magne Cum Laude.

    No, I am not proud of this fact.

    Simon is clearly on the same wavelength as every single person on the planet here. I suspect my take on the line would involve a lot more swearing though.

    ...oh. She's a bloody walking tutorial.

    FLYING. FLYING tutorial. Whatever.

    And she's god-damn useless as well. "Press ACTION"? Yeah? Well, what key's that then?

    ...tell you what. I'll let YOU guess what the ACTION key is. Go on, have a guess. I'll wait.




    ...not just scrolling down because you can't be bothered?

    ...OK then. Here's what, by default, the ACTION button is.

    ...100% sure you actually made a guess? OK.


    Yeah. Control. Because, y'know, that make PERFECT sense.

    (Oh, all right. You can use Enter as well. But they don't actually tell you that!)

    So let's use this bloomin' switch then.

    Oh wonderful. Because I'd never have figured out to do that on my own. All hail the great and powerful Godmother.

    And with that, she buggers off. Thank Christ.

    I'd like to point out I only found that funny because the Fairy Godmother is a right royal pain in the arse.

    So, what lies beyond the gate? What mystical treasures are there to be plundered? What crimes commited? What people insulted? Well I know, but you'll just have to wait and see.
  • edited December 2012
    I didn't know Minecraft had a Simon the Sorcerer mod. That's amazing!
  • SydSyd
    edited December 2012
    I agree with you on Simon's voice actor. I liked his VA in the talkie version of the first Simon game, but then (for some reason) they swapped VAs for the sequel, and also decided to change Simon from a likeable jerk to.. well, just a jerk. Simon 2 is a pretty good game as far as gameplay goes, but I have difficulty playing through it since there's quite a few moments when I'd rather punch Simon in the face than help him along on his quest.

    As for Simon 3D... yeah, I'm not going to touch that game, but I applaud you for having the bravery to play through it. Maybe if they had gotten Chris Barrie back in to voice Simon it would have been slightly more bearable, but no, they had to stick with that guy from the second game.
  • edited December 2012
    Syd wrote: »
    Simon 2 is a pretty good game as far as gameplay goes, but I have difficulty playing through it since there's quite a few moments when I'd rather punch Simon in the face than help him along on his quest.
    Oh, it gets worse. It gets so, SO much worse.

    Glad you guys are enjoying this. Not entirely sure how long I'll keep it going, but I'm hoping all the way through. We'll see.

    Quick question - are the pictures too big? That was my main concern when doing this, but if I try to resize them then the subtitles become harder to read. Thoughts?
  • SydSyd
    edited December 2012
    Quick question - are the pictures too big? That was my main concern when doing this, but if I try to resize them then the subtitles become harder to read. Thoughts?

    It's fine for me. It doesn't stretch the posts out or anything like that.

    Anyway, if the pictures were too small, we wouldn't be able to bask in the radiant glory of Simon 3D's stunning graphics.
  • edited December 2012

    Anyway, surprise! Mini-update!

    One thing I forgot to mention is this blatant bit of dickery from the Fairy Godmother.




    OK, so, yeah, this game came out in the golden age when manuals not only existed, but also actually contained useful information, including a nice list of all the controls right in the middle of the manual so that it's more than likely to be the first page you see when you open the booklet.

    Odd, then, that the game feels the need to explicitely tell you to refer to the manual while it's in the middle of its tutorial section. Y'know, that thing which is EXPLICITELY DESIGNED TO TEACH YOU HOW TO ACTUALLY PLAY THE GAME.


    The sad thing is, I did refer to the manual several times until I'd gotten the hang of the controls, and even then I had to keep going back to it whenever I had to combine inventory items, which is horrifically complicated and I'll show you in more detail when we get to it. Ugh.

    Anyway. Hope you enjoyed this little bonus segment, and hopefully a proper installment will be up soon.

    (For the record, the T-Shirt is the Game Grumps 'TenOuttaTen' one - thanks to Coolsome for telling me where to get it [and sharing the code for free postage, woo])
  • edited December 2012
    I want that shirt.
  • edited December 2012
    I got that shirt and the 7 asses one. I'm dang ass sexy.
  • edited December 2012
    ...and we're back. Sadly.

    Right, where were we?

    Oh, right. We were gonna go through that door. OK, let's head through it then.

    Ooo, what wonders could await us beyond this gate? It could be treasure, or women, or treasure, or-

    ...oh. Well that's kinda lame.

    Might as well head to the back first. Maybe there's women here?

    ...oh, it's a dead end. That's... that's nice.

    Note that plate on the floor. No idea why I'm telling you to do this. Just feel like it. Hint hint.

    Alright, we'll go the other way. Towards the camera. Because THAT isn't awkward at all.

    Now THIS is awkward. Jeez, what were the developers thinking? These camera angles are just awful. It makes controlling Simon a massive pain in the arse, especially with those Tank controls I mentioned earlier, because it means I keep running straight into things.

    ...like so.

    Anyway, once I make my way around that I head down the hall and find...

    ...a nice display thingamy.

    Now I want to look at it, so it's time for another game of...


    Yes, it's time for round two of that most irritating of quizzes! And for 10 points, your next question:






    ...padding so you don't accidentally see the answer while scrolling down...


    ...more padding...


    ...OK, here's the button you press to EXAMINE:



    Y'know, I can sort of see the logic there. X to eXamine things. But, and here's the big question, WHY THE FUCK DID THEY NOT JUST USE THE E KEY THEN? Gah!

    And all so Simon can point out that it's important for something. Well whoop-de-fucking-do, it's not like I can't tell that for myself. What is it? Are those jewels? Can I do anything with it? Does any of this sound at all important? These are the things you should be telling me Simon, not that the blatantly obviously important thing could well be a tiny bit important!

    We're barely 5 minutes into the actual game, folks. FIVE. MINUTES.


    Alright, let's just try to use the thing then, see what that does. That's the Ctrl button, remember.

    Oh, Simon just takes the three jewels. So they were jewels then. Would have been nice to know that before you picked them up, but whatever.

    So Simon takes all three remaining jewels an-

    OH FUCK NO. I do NOT want to be dealing with this bitch right about now.

    Yeah, no Shit, Sherlock.

    Mine was better.


    Actually, you can skip this one if you want, and thank christ for that, because it takes AGES to go through.

    How do I know this?

    ...because I listened to it.

    And because I did that, I can tell you of a bizarre bug that happens here. On certain lines, like this one for example:

    ...there's no audio. The game acts like there should be some, and the character moves her mouth as if she's saying something, but there's no actual audible voice. It's incredibly bizarre. What's more, it's oddly specific. There's about five or six lines from the Fairy Godmother in this chapter, and then it doesn't re-occur until Chapter Three. Very odd.

    Anyway. The blurb here explains the inventory system, which is accessed by pressing the SPACE BAR. That's not entirely unreasonable, so I'll let it slide. What I WON'T forgive is how you use an item. First you select it with the ACTION button (Ctrl or Enter, remember). It'll then be in the 'In Hand' position, shown by an image of the item appearing in the far-right box on the upper right of the screen. These boxes hide themselves away during cutscenes and dialogue (though there's so much bloody dialogue in this game that they're pretty much the same sodding thing), so I can't show you without referring to an earlier shot:

    ...like so. You then use it by pressing...

    ...oh sod it, I can't be bothered with doing the whole quiz thing again. It's Alt.

    Yes, Alt. That one key you never press because it usually brings up the 'File' menu of whatever program you're using. THAT Alt.



    Oh, and having Little Miss Exposition tell you all this without any visual aids to help show you what she's actually talking about and let you better understand what's going on is EXACTLY the sort of thing idiots who can't be bothered to do any decent programming would do, which explains why it's happening right now.

    This is just amateurish. One of the golden rules of cinema is 'Show, Don't Tell', and that's no less applicable to games. In fact, it's even MORE important, because you can do BETTER than just showing players stuff. You can guide them through it. Games are an interactive medium, after all, and the best way to get someone to understand how to do something is to actually have them do it while you're guiding them through the experience.

    But oh no, that's FAR too advanced for this game. No, Simon 3D just tells you stuff and leaves you to figure it out on your own. And then it tells you that you should probably read the manual if you're stuck.

    No. No I shouldn't. You should be doing a better job of showing me what the hell I'm supposed to be doing, you stupid, irritating, cock-sucking BITCH.




    ...a little boring?


    ...oh, thank you Simon. I guess you're not as bad as I thought you were.

    Oh, shut up.

    She goes on to explain... well, not an awful lot, really. And then she leaves.

    Oh now really, there's no need for that...

    Anyway. As we were.

    Let's continue down the hallway and see where we end up.


    Right, there we go. Now, let's see wher-


    Oh, you're just taking the piss with that one.

    I swear, I'm not doing this on purpose. The controls really are this bad! Honest!

    Right. That took some work. Let's see what's through here.


    Aha! Victory at last! Lo, I have triumphed over the terrible controls and horrendous camera angles! And there's a key. Lovely. I'll just walk up and grab that...

    The flying moonshine is that? Is a giant robot falling from the ceiling?

    Ah. That'd be a yes then.

    Oh Simon, you loveable coward. Quick, grab it and shove it back on your head before the camera has a chance to cut back to you, because then the programmers don't have to make a separate model of you without the hat on!

    ...phew. That was a close one. Who cares if it made the cutscene awkward to watch, we have lazy coders to deal with!

    OK, I think I've broken everyone's bandwidth enough for one day. We'll see how Simon deals with the giant robot who (spoiler) genuinely can't hurt you at all (no, seriously) in the next instalment.

    Actually, I'd encourage people to post in this thread, if only so we can break my posts over several pages. It'll help reduce the loading times for each page. They're only PNG files from my Photobucket account, but even so, I can't imagine loading over a hundred images on one forum page alone is a good thing.
  • edited December 2012
    I can't think of the last game I played that controlled like that.
  • edited December 2012
    It actually feels very similar to the early Tomb Raider games, if you can cast your mind that far back.

    Well, there's no jumping or shooting stuff (yet...), but you get the idea. It feels like an early 3D platformer. Which is odd, considering it's supposed to be an adventure game.
  • SydSyd
    edited December 2012
    Tank-style controls are my worst enemy, and it's made even worse when the camera angle suddenly changes. As much as I love Grim Fandango, there's quite a few times that I ended up running straight into a wall because of the controls and camera, but at least Grim's controls were mostly sensible (and it has the excuse of that sort of control scheme being popular at the time). Simon 3D's controls look like a nightmare. What were they thinking?

    And of course, it goes without saying, but those are some horrible graphics. Considering the capabilities of computers at the time, there's just no excuse for the game to look that bad.
  • edited December 2012
    Oddly enough, I've never found that particular control scheme to be much of a problem, possibly because Escape from Monkey Island was the first game that I played that controlled from a third person perspective. Though that one used the arrow keys, which I now find really annoying since I'm so used to steering characters with my left hand.
  • edited December 2012
    And this is what you play instead of the actually good games you bought?
  • JenniferJennifer Moderator
    edited December 2012
    If only the fan project to adapt the game to use the graphics and interface of the first two Simon games didn't die out. I played the demo of that one, and it seemed quite fun (the areas you played above were part of it, and they were actually enjoyable). It's a shame even the demo doesn't seem to be available anymore.
  • edited December 2012
    Here's a video of said project. You're right - it looks way better.

    Well, except for the chamber. That... that doesn't look so great.

    Oh, and here's the Demo itself. Not sure what language it is.

    EDIT: I'll be trying to upload one part of this Let's Play per day. Currently working on today's part.
  • edited December 2012
    The demo is in German, of course.
  • edited December 2012
    Oh well. Us English speakers still get the gist of it at least.

    Basically the opening cutscene from the demo takes about a fifth as long as the actual game, which takes almost 8 minutes from hitting New Game to actually being able to first control Simon. When I said I was getting Daikatana flashbacks, I wasn't kidding (I did say I was getting Daikatana flashbacks, right?).
  • edited December 2012
    Right. Let's defeat that robot thing!
    That robot's totally preventing us from getting that key!


    And here we are inside the chamber again. Now as you can see, the robot's in the center there, and it'll follow you around as you move around the room, constantly blocking off the key. Aside from that, it does absolutely nothing, and if you walk too close to it, Simon simply backs away. I forgot to shoot him doing this, so you'll have to accept this image taken from someone else's Let's Play (hope OreWaUsoop doesn't mind):


    I've wandered around the chamber a little here to get a better angle of the laser beam. It's a bit hard to tell thanks to the poor camera, but if you move round then the robot will follow you and move directly into the path of this beam. This may factor into how we defeat it. Possibly. Maybe.

    Anyway. Simon's standing right in front of something, so let's have a look at it.

    Oh, it looks like there's space for something, does it? Gee, I wonder what we have that could possibly fit in there.

    Oh right, THE ONLY THINGS WE'RE CARRYING. How did that slip my mind?

    You can see the inventory thing in the top right, by the way. The blue jewel's what's currently selected, which is handy, since I'm using it and all.

    Rinse and repeat...

    And here's what we're doing, in case you hadn't guessed. We've just the green gem to go, so...

    ...there we go. Now we just need to make the robot enter the area where all four beams cross...

    ...like so...


    ...is it odd that I feel kind of sorry for it now?

    That's our Simon! He's definitely got his priorities straight.

    ...so, let's take the key and get out of here.

    And now, because nobody asked for it, here's the inventory screen!


    As you can see, it's a bit empty at the moment. Now the way the game's explained things so far, you'd think that you had to come to this sreen every time you want to select an item from your inventory. You actually don't - there's a button that lets you cycle through your inventory items one at a time, and that's what I used to select the gems, because otherwise it'd take twice as long.

    You'll notice I haven't told you what the keyboard command for that is. There's a reason for that, and we'll get to it in a bit.

    Anyway. You'll also notice three tabs at the top of the book here. Disk contains the Save/Load features and lets you quit to the main menu (which you can also do by pressing Esc - trust me, it'll take you a while to get used to bringing up your inventory so you can save), and the Opt tab contains the options. I won't go into great detail about those, since they're fairly standard, if a bit basic. Worth noting though that the maximum resolution is 1024x768. Joy.

    Right. That's that discussed. Let's open that blasted door.

    There we go. Now, onwards!

    Ah, it's another one of those plates. It's got an Egyptian symbol on it, according to Simon. If you look closely at it you can tell it's an Ankh, which means absolutely nothing, but it's vaguely mystical and that's good enough for this game.

    Oh, piss off, woman.

    So this she-devil explains that these things on the floor are LIFE PADS. Basically, if you die, you'll be resurrected on the nearest one of these.

    ...uh, why is she telling me this now?

    This is, I feel, one of the few genuinely funny lines in this entire game. Treasure it folks, we won't get another for quite some time.

    So, that done, we head on dow-


    This is another one of those lines without audible dialogue, by the wa- Wait, SPRINT? Why would I need to sprint down a large corridor?


    ...you can see what's coming, can't you.


    ...not uh, not quite on the same level, are they.

    Especially not when you have to contend with a wall right in front of you as soon as the game lets you control Simon again...


    ...a corridor so dark you can't tell what's in it...


    ...and a dead end that you'll need to SLOWLY turn around and run out of.


    So for the first couple of tries, this will happen.


    ...and so, on the bloody, splattered corpse of our main protagonist, I think we'll end this particular segment.
  • SydSyd
    edited December 2012
    Knowing how incredibly massive of a jerkwad Simon could be in Simon 2, and how he's apparently managed to become even less likable in Simon 3D, there's something strangely satisfying about seeing him as a bloodstain on the ground.
  • edited January 2013
    ...and we're back. Again.

    So after about a dozen tries, I finally make it into the doorway you're supposed to go into:


    This leads to...

    ...a giant room full of pillars. But how do we get across with no jump button?

    Oh just die already.




    So anyway, it looks like it's time for another tutorial. What are we going to learn this time?

    Huh. That... that seems a little weird. If she's saying this to Simon, then that means she's telling him how to see things through his own eyes... which he does already. Surely this should be directed at us - the players - rather than Simon.


    ...well, never mind then.

    This fourth-wall breaking is getting rather annoying, actually. It's hard to get at all invested in the world when the lead character, the one we're controlling, in staggeringly genre-savvy. This is far from the first, or indeed the last, time he'll say things like this, and while the odd comment can work, this is very much overkill.

    Anyway. All the clueless bint's really telling us is how to use First-Person mode. By holding down the TAB key, we see through Simon's eyes, rather than whatever atrocious camera angle the game's currently using. You can't move while holding it down.

    Apparently, we can see stuff we wouldn't normally be able to, such as in this room, but so far as I can tell, this is the only time we ever actually need to use it, so basically YOU WILL NEVER ACTUALLY NEED TO USE THIS TO FINISH THE GAME, and the only times you may want to use it are when you want to take a closer look at a random sign or whatever (and even then you probably won't be able to make it out due to the poor graphics).

    All right then, let's at least give it a try.



    Yes, that path is only visible when you use the LOOK key, so you'll have to carefully make your way across while constantly checking to make sure on it. This will not get old at all.


    ...are we having fun yet?


    ...ugh. Next.

    Oh yes, that's MUCH better. :rolleyes:


    Oh, here we go. Time for a final round of GUESS THE BUTTON!

    Since it's the last round, we've got two keys for you to guess here. Going back to earlier, I mentioned there was a button that let you cycle through your inventory items one at a time. I want you to guess that key.


    I want you to guess the button for CROUCH.

    Just to be fair, here's a reminder of the keys identified so far:

    USE - Ctrl / Enter
    LOOK - Tab
    WALK - Shift (OK, I forgot to mention that, but you could probably have guessed it)
    SPRINT - Caps Lock (Forgot to mention that as well. Oops)

    So, remember: I want you to guess what the keyboard commands for CYCLE INVENTORY ITEMS and CROUCH are. Go!







    Times up!

    Are you ready?

    OK. We'll go with CROUCH first. What did you guess?

    Well, if you said it was C, then...


    I know, right? But the ACTUAL button to crouch is...


    Which, y'know, is KIND of understandable. But, see, this is why I got you guess CYCLE INVENTORY as well, and no matter what you thought it was before, you can probably tell what it's going to be now, can't you.


    ...yup. So CROUCH is Z, and CYCLE INVENTORY is C.

    Please tell me I'm not the only one who sees the failure of logic in this choice. Please.

    Anyway. Don't let the eye see me, huh? OK, well, that shouldn't be a problem.

    Oh. That... that might be an issue.

    Well, actually, it's not. The eye does a look-left-look-right movement every 6 seconds or so, and as long as crawl around and make sure you're behind one of the bits of cover you can see dotted around while it does that, then you're fine.

    Unfortunately, I'm just so damned awesome that I aced this section on my first try, so I don't have any images of me failing miserably. Fortunately, that guy on YouTube is nowhere near as cool as me, so here's what happens when you do get spotted:


    See inside that big white circle? That's a fireball the eye shoots at you. If it hits you, you just fade out of existance and re-emerge back where the Fairy Gitmother (heh) was just talking to you.

    Anyway, back to me being awesome:

    Here I am crouching (it goes to a First-Person viewpoint when you do this, presumably so the developers wouldn't have to make a crawling animation, the lazy buggers) and waiting until the eye does its sweep.

    Having finished the sweep, the eye's clear for a few seoconds, so I crawl over to the switch.

    ...and use it. It opens a gate on the other side of the room, which I now need to get to.

    ...like so...

    ...and boom! Done. Seriously - I rock.

    And here lies a big ol' door. Could this, finally, be the way outside?

    IT IS!


    ...and that'll do for this part. Next time, I bitch about being outside. A lot.
  • edited January 2013
    Heh, I like Simon in Simon 2.
  • edited January 2013
    I'm just now catching up on things after a busy holiday season, so I started reading this from the top today, and I thought I'd write another message to bump more segments to the next page.

    First of all, the images look the right size to me, close to the same size that St. Eddie is using. You're not making the forums widen the message boxes, which is good.

    I like your comments so far, but I think you're putting in too many images. There are a lot of places where you could just put in a couple, and we'd get the idea. If there are this many images in just the opening segment, we're going to have to look at an awful lot to get through the game! You can always add a "Be thankful I'm not showing you all this" comment, as St. Eddie does from time to time.

    Overall, looking good!
  • edited January 2013
    Too many images, check. I'll try and cut back a bit.
  • edited January 2013
    ...and we're back.

    As I'm sure you recall, we're outside now. So let me give you a basic rundown of what there is in this area via the magic of a text overlay:


    As you can probably guess, Simon is currently in the middle of that circle in the middle of the screen, having just left the temple/pyramid/whatever. Off in the various directions I've indicated are the main items of interest. There's also a phone box (a RED phone box) off to the lower right, but since it's broken and can't be used (YET), I'm not going to show it.

    To start, we should probably head over to the temple priest guy on the left.


    ...and here he is.

    I'm going to sum up the incredibly long and boring conversation you have with him. Be thankful, it goes on for a while. Everyone in this game (except for Simon) takes FOREVER to say their lines, which is irritating if you've got subtitles on and can read rather quickly. Like me.

    Basically, the rejoining process worked, but in order to finish it, you need to eat a fruit from the Sacred Tree. Until you do so, Simon will occasionally turn translucent for a second.


    ...like so.

    So you need to eat a Peach from that Sacred Tree. The game explains that the tree absorbs souls who have died and essentially distills them into peaches filled with 'life energy', and that's what you need to complete the joining process.

    BUT (there's always a but).

    Before you go out and grab one, you're given this warning about not waiting for one to fall on its own:


    I want you to remember that. REMEMBER IT WELL.

    The guy also gives you a letter from Calypso, who was the other wizard from the opening cutscene - the one with the staff and Simon's soul. He's from the previous two games, and the game makes no attempt to hide this, which would probably be a bit confusing for new players. You had to rescue him from the villain Sordid in the first game, and he did bugger all in the second game aside from having a hot granddaughter (who was actually fairly hot since that was when the series was still 2D) for Simon to unsubtly lust after in a very unfomfortable manner.

    ...sorry, got a bit sidetracked there.

    Simon automaticaly reads the letter, which triggers another long and boring cutscene. I'll summarize it for you. I'm too good to you people, I really am.


    "Dear Simon,

    Blah blah blah.

    Come to Poliganis and meet me ASAP so I can explain what's going on.

    Blah blah blah.

    Also, there's a hot chick here you'll probably want to meet. Well, I say hot, but you'll have to rely on fan-art to establish that because she looks like someone tried to made a sex doll out of painted blocks of polystyrene.

    Blah blah blah.

    Love, Calypso."

    So there you go. There's a few other things we need to do here, so we might as well get them over with. Let's head to the top of the pyramid thing first.


    I'll skip over this guy's dialogue as well.

    Actually, I'll pretty much be skipping over EVERYONE'S dialogue, since (as already stated) they take forever to get to the point. So you'll be seeing me doing a lot of summarizing from this point on. Good? Bad? Whatever. It's my Let's Play, and I'll do it however I want. So there.

    The guy up there is the Keeper of the Soul Bell. Every time someone dies untimely, he rings the bell to guide souls to the Spirit Tree. He's been doing this for seven years and he's bloody knackered, pretty much running solely on caffeine. A bit like me then, ba-dum tish.

    But we don't want anything to do with him (yet). So we're just gonna nick the telescope in the bottom left there. BECAUSE WE CAN.

    (OK, Simon actually just tries to use it, but he barely touches it and it comes loose. so he figures 'what the hell')


    We now have two new inventory items. The lens, which fell out the minute we pick up the telescope, and the main body of the scope itself. One of these will be used in a reasonable manner. The other... well, you'll see.

    We're gonna head over to the buildings now. Remember them? They were on the right side of the earlier picture.


    Oh no, sorry. We have to go through a pointless bit of corridor first. FOR NO GOOD REASON. This is an ill omen.


    Anyway. There's a bunch of buildings here. You can go in one, but it's basically a barn, and we've no use for it yet so I won't bother showing it until the time comes. The only other building we can enter... we can't enter JUST yet. So let's head to the back corner of this area, where we find...


    ...uh. What's this guy doing?

    He won't respond if you just try to talk to him. In fact, the only way to get him to talk to you is to actually enter the pool of water he's standing in, at which point he asks...


    More summarizing!

    The guy's name is Judas - nicely subtle there, game - and he's in this pool of water (actually the Pool of Punishment™) because he took a peach from the Sacred Tree and ate it. Remember earlier when I told you to, well, remember something?

    Do you remember what that was?


    So that means that in taking that peach, he inadvertently took the life of an innocent. Wow. This takes on a whole new meaning, doesn't it?

    And does the game focus on this point at all?



    He tells us that he wants us to take his Chakara away from him (to remove future temptation or some bollocks), and that he left it under his bed in his house. We can now enter said house - the game wouldn't let us before - and retrieve said item, so let's do that.


    ...yes, those are indeed naughty magazines. You have to pick them up to get the Chakara.

    Actually, at this point I seem to recall the original unpatched version of the game having a glitch that stopped you from progressing at this point. I think it stopped you from crouching? I can't find any reference to it on the net, but I swear I am NOT making this up. It happened the very first time I played this game, years ago. Honest!

    Anyway. Not only do we now have some adult magazines (featuring Nuns, no less!), but we've also found the Chakara. Simon promptly shows it to us.


    That's not a Chakara! It's a... a...


    Yes, that's it. A kite. Honestly, who are they trying to fool here? Right, so let's go and commit the most horrible crime possibl-



    Long story short, she tells you how to use the kite. You equip it in the 'In-Hand' position and then use it. You'll go to a First-Person mode, from which you'll need to aim it and use it like you would an actual weapon. Only you can't use the mouse. And the movement keys are awkward to use. And there's no crosshair. Hmm.

    Apparently using it can let you grab items from a distance. You really won't use it all that much though, so chances are by the time you'll actually need to use it again (which doesn't happen for a couple of hours) you'll have forgotten all about it. Wonderful.

    Anyway. That's all she say-


    ...is she actively telling you to do what I think she's telling you to do?


    Why do I have to keep reminding people of this? EATING A PEACH EARLY KILLS SOMEONE. I don't care how light-hearted and brightly coloured your game is, this is not something I want to do!

    But, naturally, the game won't let me progress until I do, so here we go.


    ...and having taken but ONE BITE of the thing, he promptly throws it away.


    Oh no, I'm sure NOTHING bad will come of this.


    ...look it up.

    And how does Simon celebrate his rejoining?


    ...by buying a can of Croca Cola. Party time!


    Anyway, it's time to leave. We talk to the priest guy (who doesn't say anything important) and then head for the gate. The guard there (who you can JUST see behind Simon's head) now lets us out and into the big wide world.

    And I do mean BIG.

    ...but we'll leave that 'til next time.
  • edited January 2013
    The LP is now at the point where I just gave up on the game because I couldn't take this bullshit any more and because there was no more room in my hose. The game made me kill too many people...
  • edited January 2013
    I'm gonna have to start a count of all the felonies Simon commits. Theft is the least serious.
  • edited January 2013
    Too many images, check. I'll try and cut back a bit.

    Overall I think you've found a good balance, but it was a bit much with the hidden path and those death scenes.

    I'm enjoying this immensely, but seeing this makes me glad I never actually played the game. Teen me must have had pretty good taste for not picking this up back then, even with the limited number of games I had any interest in at the time and despite being a big fan of the two first installments in the series.

    EDIT: Wait, this came out two years after Escape from Monkey Island!? EfMI might not hold up too well graphics wise, but it still looks a lot better than this atrocity.
  • edited January 2013
    Are you sure you're not playing as the bad guy in this game?

    Ah well, this latest installment does a better job of only showing the interesting/important images, thanks!
  • edited January 2013
    flesk wrote: »
    EDIT: Wait, this came out two years after Escape from Monkey Island!? EfMI might not hold up too well graphics wise, but it still looks a lot better than this atrocity.

    Hell, Escape looks positively gorgeous compared to this.


  • edited January 2013
    Oh god, you're right. After staring at a series of Simon 3D screenshots, Escape looks fucking beautiful.
  • edited January 2013
    I think it's because of all the detail. There were no truly barren scenes in Escape. Maybe you couldn't interact with all the stuff, but there was always tons of things in the background to look at. It's one of the things that I don't think got enough credit in the game.

    By today's standards, it hasn't aged well, but I remember starting up the game after playing those early 3D Harry Potter games and being completely blown away by how pretty it was in comparison.
  • edited January 2013
    Time to completely and utterly blow your minds.

    Simon the Sorcerer 3D is made with the NDL NetImmerse 3D engine.

    Would you like to see some other games that used the NDL NetImmerse engine?

    Freedom Force vs the Third Reich:

    Oddworld: Munch's Odyssey:

    Call of Cthulhu - Dark Corners of the Earth:

    ...and my personal favourite, and the one that's really makes everyone go "WHAT?", fucking Morrowind:

    And for comparison's sake, here's Simon 3D again:

    ...doesn't quite hold up, does it?
  • edited January 2013

    You really weren't kidding about the programmers being lazy.
  • edited January 2013
    Yeah... Normally I don't really complain about graphics, but this is definitely a case of not going the full mile.
  • edited January 2013
    It's a combination of the developers' lack of experience with 3D and the fact that the game apparently went gold two years before it actually came out in 2002. Had it come out in 2000...

    ...well, it would still look awful.
  • JenniferJennifer Moderator
    edited January 2013
    der_ketzer wrote: »
    The demo is in German, of course.
    Oh well. Us English speakers still get the gist of it at least.

    Basically the opening cutscene from the demo takes about a fifth as long as the actual game, which takes almost 8 minutes from hitting New Game to actually being able to first control Simon. When I said I was getting Daikatana flashbacks, I wasn't kidding (I did say I was getting Daikatana flashbacks, right?).
    I found a site that still has the demo in English here. It's too bad Adventuresoft was forced to go 3D for this, as it seems like it might be at least a decent game in 2D.
Sign in to comment in this discussion.