Severe Text Glitches.

I bought your masterful game from Mac Game Store a couple of days ago and I tried it today for the first time.
And from the opening sequence I experienced the horror. Glitches are creepier than the undead :)

The Problem
While the game loads well and the menus are presented pristinely, the proper game showed, since the very start, lethal text glitches during the intro and then during the in-game dialogues.

It seems to be only the text of a particular font (or the particular use of that text - EG: As a title or header), but I have no way to verify this claim.

I am here including a mosaic o 4 screencaps for clarity:

Attempted solutions
These couple of things can barely be called solutions, but I gave them a shot anyway.

1) Re-started the game. Re-started my computer.
None of these things made any difference.

2) I can't re-install the game since it downloaded fully functional from Mac Game Store just to be dragged into my Applications folder and that unique copy is what I have been using.

3) I played with the Preferences of the game too:
Used it with Anti-Alised turned off and turned on. Same results.
Played with the lowest resolution selected and the highest. Same results.

Operating System Specs
21.5-inch, Late 2012
Mac OSX 10.8.2 (12C2034) Mountain Lion
Processor 2.7 GHz Intel Core i5
Memory 8 GB 1600 MHz DDR3
Graphics NVIDIA GeForce GT 640M 512 MB

If there is any more information you need to solve this mystery, please let me know.

Much obliged


  • DjNDBDjNDB Moderator
    edited January 2013
    Do they look normal if you put the game into windowed mode by pressing Command + F?
  • edited January 2013
    DjNDB wrote: »
    Do they look normal if you put the game into windowed mode by pressing Command + F?

    Yes, the text does look normal in windowed mode.

    Thank you very much. Now at least I have a runaround for the problem.
    Is it a known glitch? I ask because I would like to play the game in full screen mode and if it is a known bug then maybe there is a fix.

    Thanks a lot for your reply. I hope the next one is: Yep, there is a fix for it :)
  • DjNDBDjNDB Moderator
    edited January 2013
    There are some threads about it.
    I saw someone fixing it for the fullscreen mode, by playing around with the resolution and disabling anti-aliasing.
  • edited January 2013
    Thank you. I will follow that advice and if it does not work I'll just keep messing about with the Settings of the game.
    Much obliged DjNDB ;)

    UPDATE (January 6, 2013): SUCCESS!
    The instructions on the link provided above worked perfectly for me and fixed the issue.
    Another gamer by the handle iDiPirro found a way to resolve the issue (almost)* permanently.
    For those that arrived to this post searching for the same text issue, and have not seen iDiPirro's post yet, here is basically what he did:

    1) Go to Settings and turn off Fullscreen (Shortcut: ⌘F).
    2) After you've done that, bring the Resolution to 1280.
    3) Then turn off Anti-aliasing.

    The text should be perfectly legible from now on.

    After you have done all of the above you can then revert all the settings to whatever you prefer, (including maxing all the settings and even turning Anti-aliasing back on, if that is what you like) and it should still work perfectly.

    The glitch may return, but if it does just quickly repeat the first 2 steps of the method described above and you're good to go again, at least for the duration of the session you play.
This discussion has been closed.