User Avatar Image

TWD crash on connecting

posted by halldorr on - last edited - Viewed by 8.3K users
Picked up a copy of TWD for my wife on Steam as I loved the game but she just can't play the damn thing. We have identical computers as far as hardware goes and it ran just fine for me.

Here are the things we've pulled from the forums and tried so far:

1) Played with compatibility sittings, tried them all but no luck
2) Set run as administrator, no luck, set to all users, no luck
3) Tried replacing a DLL here and there as suggested, no luck
4) We don't have controllers but we pulled all USB stuff one by one, no luck
5) Disable internet connection - this appeared to work

Is there a fix to this? I'd like her to be able to play as the game intended and have the Steam sync work properly for her without having to always disabling her internet connection.

We're both on Windows 7 64bit and we connect tot he web through a home router. Seems odd that it would crash on connecting but that is where we seem to have an issue every time.
151 Comments - Linear Discussion: Classic Style
  • Unplugging and disabling the device did not change anything.
    I didn't notice any edit about process monitor. I just have confirmed i have saved the log only after Walking Dead process was terminated.

    About logs, here are My logs

    However they are only the ones from the "log" folder, i had no other log files anywhere.
  • User Avatar Image
    DjNDB Moderator
    Thanks. I meant this edit quoted below. But you can do that tomorrow.
    DjNDB;757502 said:

    It might also be useful if you did another process monitor log, running the game error free, with the network disabled.
    That way i could compare them, instead of trying to compare it with a log from my system.
    I found something weird in the process monitor.

    c:\ProgramData\VKSaver\vksaver3.dll from the company is a dll that's loaded into the WalkingDead101.exe that shouldn't be there.

    I'll check the logs now.
  • Closed VKSaver and still no luck.

    Added the log of the game with no net (Where it skipped through the connecting part all together and i just clicked on "Exit game")

    Link re-post - Right here

    I am gonna sleep now (Almost 3 AM and gotta wake up at 5 XD )

    Talk to you from my work place tomorrow, or after i get back from work so we can test more.
  • User Avatar Image
    DjNDB Moderator
    Alright, sleep well.

    I found nothing useful in the steam logs.
    There are a lot of failed connections in the connection_log.txt, but not at the time the game crashed and also from much earlier dates. I don't know what that's about, but i don't have such issues in my steam log.
  • User Avatar Image
    DjNDB Moderator
    I compared your process monitor logs. It's hard to draw conclusions from that, but i could find the time when the game crashed.
    It might be random, but one of the last things the game does before it crashes is including C:\Windows\SysWOW64\FWPUCLNT.DLL (FWP/IPSec Usermode API).
    It doesn't do that in your unconnected log. Since IPSec is network related, i found that even more suspicious.

    I took a look at the files details, and then i noticed that it's older than the one on my Win7 system. Yours is version 6.1.7600.16385, while mine is 6.1.7601.17514. I tried to find out why, and then looking at your dxdiag again i found this:
    perilomo;757372 said:

    Operating System: Windows 7 Ultimate 64-bit (6.1, Build 7600) (7600.win7_rtm.090713-1255)
    It's easy to miss, but your Windows 7 is not up to date. The latest is 7601.win7sp1_gdr.120830-0333.

    All that might not be the reason for the crash, but it's definitely something to look at. Please try installing the latest windows updates and SP1.
  • Will get home today after work and will try that out.

    Thanks for the assistance, hopefully it'll resolve my issue


    Forgot it's a fresh install of Windows and i haven't installed windows updates yet -.-

    Edit 2:

    Could you by any chance point me to the corresponding update name? As i don't wanna update useless crap like Internet Explorer etc on my PC. If not, then at least the row number in the DxDiag file where i can find the version of my system so i can just check later after installing the update.

    Thanks in advance
  • User Avatar Image
    DjNDB Moderator
    I don't know which updates you need, i would do them all to be sure.

    It's right there in the beginning:
    perilomo;757372 said:

    System Information
    Time of this report: 1/5/2013, 22:40:13
    Machine name: JEKKA-PC
    Operating System: Windows 7 Ultimate 64-bit (6.1, Build 7600) (7600.win7_rtm.090713-1255)
    I also had another idea. It might be worth a try to update your network device drivers.
    Before that, please go to the device manager and post the driver version and date of your Realtek Adapters (Wired and Wireless) for reference. You find them by right clicking each Adapter, and selecting "properties", and then opening the "driver" tab.
  • Hehe, will have to wait till i get back home later this evening.
    Thanks a lot for the help though. I will do it first thing i am home!
  • As of my current network adapter drivers :

    Ethernet adapter
    Wireless adapter

    Gonna look for drivers now
  • User Avatar Image
    DjNDB Moderator
    perilomo;757828 said:
    As of my current network adapter drivers :

    Ethernet adapter
    Wireless adapter

    Gonna look for drivers now
    The drivers are indeed horribly old. Let's hope that's it.

    I already looked them up yesterday :)

    Download and install the Auto Installation for Win7.

    Realtek Wireless:

    Realtek Wired:
This discussion has been closed.