Telltale Autumn Sale

My support_data_mac file for TWD

Attached is the support_data_mac.zip file for my MacBook Pro running OSX Lion.

I have done everything that MattP, DjNDB, and others have said. Yet, I am still not able to play Episode 2 with my decisions. Please use this file to create a fix.

Comments

  • DjNDBDjNDB Moderator
    edited February 2013
    Good move.
    prefs.prop Locations:
    -rw-r--r-- 1 nateblank staff 29K Feb 13 19:51 /Users/nateblank/Library/Application Support/Steam/SteamApps/common/The Walking Dead/TheWalkingDead.app/Contents/Resources/Pack/default/prefs.prop
    -rw-r--r-- 1 nateblank staff 2.3K Feb 13 19:54 /Users/nateblank/Library/Application Support/Telltale Games/TheWalkingDead/prefs.prop

    You have multiple prefs.prop files, and the one in the savegame folder appears to be corrupted.
    Please open a terminal and run the following command line. It's a single line command:

    mv ~/Library/Application\ Support/Steam/SteamApps/common/The\ Walking\ Dead/TheWalkingDead.app/Contents/Resources/Pack/default/prefs.prop ~/Library/Application\ Support/Telltale\ Games/TheWalkingDead/prefs.prop
  • edited February 2013
    I... think... it... WORKED! As of right now, it continued into Episode 2 with my decisions. Someone needs to pay this man (or woman)!

    Thank you, DjNDB!
  • edited February 2013
    DjNDB wrote: »
    Good move.
    prefs.prop Locations:


    You have multiple prefs.prop files, and the one in the savegame folder appears to be corrupted.
    Please open a terminal and run the following command line. It's a single line command:

    mv ~/Library/Application\ Support/Steam/SteamApps/common/The\ Walking\ Dead/TheWalkingDead.app/Contents/Resources/Pack/default/prefs.prop ~/Library/Application\ Support/Telltale\ Games/TheWalkingDead/prefs.prop

    It is back to the familiar hiccups. It will not allow me to continue into Episode 3. Is it safe to run that script again? In other words, the script was not tied to any specific save was it?
  • DjNDBDjNDB Moderator
    edited February 2013
    It is back to the familiar hiccups. It will not allow me to continue into Episode 3. Is it safe to run that script again? In other words, the script was not tied to any specific save was it?

    Instead, please run the support tool again, so I can see what's going on at this moment.
  • edited February 2013
    I wanted to see where it would take me if I started the game and it brought me back to almost the beginning. Also, for the past 3 days the save game in Slot 1 (the only save I have) says that it is from 3 days ago, the 14th.
  • edited February 2013
    I wanted to see where it would take me if I started the game and it brought me back to almost the beginning. Also, for the past 3 days the save game in Slot 1 (the only save I have) says that it is from 3 days ago, the 14th.

    I apologize, I meant almost all the way to the beginning of Episode 2.
  • DjNDBDjNDB Moderator
    edited February 2013
    This time there is no second prefs.prop on your system, so the previous fix won't work.
    Also the prefs.prop is smaller than the last time, which means that some progress might have been lost.

    Did you run the support tool before or after starting at the beginning of Episode 2?
  • edited February 2013
    DjNDB wrote: »
    This time there is no second prefs.prop on your system, so the previous fix won't work.
    Also the prefs.prop is smaller than the last time, which means that some progress might have been lost.

    Did you run the support tool before or after starting at the beginning of Episode 2?

    I mistakenly ran the script after posting my first reply today and before you told me to run the support tool first.
  • DjNDBDjNDB Moderator
    edited February 2013
    I mistakenly ran the script after posting my first reply today and before you told me to run the support tool first.

    Oh, i see. Then you must have overwritten your progress that way :(
    If you didn't get an error message running the script, then there indeed was a second prefs.prop before. Looking at the result, the one you overwrote was the one we would have wanted to keep.
    That's why i wanted to see the output first. It depends on the size and date of the prefs.prop which one should be kept or removed.
    Unless you have any backup of the prefs.prop or a way to restore a previous state, your Episode 2 progress is probably lost for good.
  • edited February 2013
    DjNDB wrote: »
    Oh, i see. Then you must have overwritten your progress that way :(
    If you didn't get an error message running the script, then there indeed was a second prefs.prop before. Looking at the result, the one you overwrote was the one we would have wanted to keep.
    That's why i wanted to see the output first. It depends on the size and date of the prefs.prop which one should be kept or removed.
    Unless you have any backup of the prefs.prop or a way to restore a previous state, your Episode 2 progress is probably lost for good.

    Fortunately, I hacked Time Machine to run on a non-Apple network drive and should be able to revert back to before running the script. Instead of reverting my entire OS back to that time, what folder(s) should I look for?
  • DjNDBDjNDB Moderator
    edited February 2013
    Fortunately, I hacked Time Machine to run on a non-Apple network drive and should be able to revert back to before running the script. Instead of reverting my entire OS back to that time, what folder(s) should I look for?

    Ah, that's fortunate.

    Ideally you would restore both prefs.props and run the support tool again, so i can see their data before deciding anything:

    /Users/nateblank/Library/Application Support/Steam/SteamApps/common/The Walking Dead/TheWalkingDead.app/Contents/Resources/Pack/default/prefs.prop

    /Users/nateblank/Library/Application Support/Telltale Games/TheWalkingDead/prefs.prop
  • edited February 2013
    DjNDB wrote: »
    Ah, that's fortunate.

    Ideally you would restore both prefs.props and run the support tool again, so i can see their data before deciding anything:

    /Users/nateblank/Library/Application Support/Steam/SteamApps/common/The Walking Dead/TheWalkingDead.app/Contents/Resources/Pack/default/prefs.prop

    /Users/nateblank/Library/Application Support/Telltale Games/TheWalkingDead/prefs.prop

    I really hope this worked. I went back to today at 12:10am (it is currently 2:29pm).

    Btw, I didn't realize that I would have to right click on thewalkingdead.app in order to find the other prefs.prop save file, hence why I only thought that I had one.
  • DjNDBDjNDB Moderator
    edited February 2013
    -rw-r--r-- 1 nateblank staff 26K Feb 16 15:27 /Users/nateblank/Library/Application Support/Steam/SteamApps/common/The Walking Dead/TheWalkingDead.app/Contents/Resources/Pack/default/prefs.prop
    -rw-r--r-- 1 nateblank staff 35K Feb 16 16:42 /Users/nateblank/Library/Application Support/Telltale Games/TheWalkingDead/prefs.prop

    Alright, this looks promising.
    Deleting the smaller prefs.prop should fix it:

    rm ~/Library/Application\ Support/Steam/SteamApps/common/The\ Walking\ Dead/TheWalkingDead.app/Contents/Resources/Pack/default/prefs.prop

    Since this is the second time it happens, we could try to prevent it from happening again, by creating a symlink between the two locations.

    ln -s ~/Library/Application\ Support/Telltale\ Games/TheWalkingDead/prefs.prop ~/Library/Application\ Support/Steam/SteamApps/common/The\ Walking\ Dead/TheWalkingDead.app/Contents/Resources/Pack/default/prefs.prop

    It's experimental, but could help. If anything should not work as expected afterwards, just post here again.
  • edited February 2013
    DjNDB wrote: »
    Alright, this looks promising.
    Deleting the smaller prefs.prop should fix it:

    rm ~/Library/Application\ Support/Steam/SteamApps/common/The\ Walking\ Dead/TheWalkingDead.app/Contents/Resources/Pack/default/prefs.prop

    Since this is the second time it happens, we could try to prevent it from happening again, by creating a symlink between the two locations.

    ln -s ~/Library/Application\ Support/Telltale\ Games/TheWalkingDead/prefs.prop ~/Library/Application\ Support/Steam/SteamApps/common/The\ Walking\ Dead/TheWalkingDead.app/Contents/Resources/Pack/default/prefs.prop

    It's experimental, but could help. If anything should not work as expected afterwards, just post here again.

    So, you're saying to run the first script to delete the smaller prefs.prop file and then run the second script to (possibly) make sure that the prefs.prop file is always the same in both folders. Am I understanding the gist of this?
  • DjNDBDjNDB Moderator
    edited February 2013
    So, you're saying to run the first script to delete the smaller prefs.prop file and then run the second script to (possibly) make sure that the prefs.prop file is always the same in both folders. Am I understanding the gist of this?

    Yes, exactly.
  • edited February 2013
    Alright, I just successfully ran the two scripts. I'll report back after a couple of saves.

    Once again, thank you for your continued interest in finding a fix!
  • DjNDBDjNDB Moderator
    edited February 2013
    You're welcome. I hope it works.
  • edited February 2013
    DjNDB wrote: »
    You're welcome. I hope it works.

    So, not only was I able to start from each of my save points as I'd close out of the game and come back, more importantly, I finished Episode 3, let the credits run, closed the game out, started the game back up (with the correct date and time in the save slot) and BAM! There's Episode 4 starting up before my very eyes!

    As of right now, it appears that your symlink works! I'll keep you posted. This is the most confident I've felt about the game in a long time!
  • edited February 2013
    I have almost completed Episode 4 and the symlink fix seems to really do the trick! Hopefully TellTale Games will add this into the Steam version!
This discussion has been closed.