User Avatar Image

Mac user: TWD crashes on episode 2

posted by JJSaccolo on - last edited - Viewed by 1.3K users
Hi,
I'm playing The Walking Dead via Steam with a MacbookPro.

MINOR SPOILER
At the beginning of the game I've to cut the leg of a guy trapped in a trap.
At the second time that my axe try to cut the leg, the game freezes.
Not only: I can't quit the game, cmd+tab doesn't works, cmd+alt+esc doesn't works, cmd+q doesn't works... the only solution is to force my mac to shut down (using the power button).

my mac is this (I'm using the NVidia 9600):
Hardware:

    Hardware Overview:

      Model Name: MacBook Pro
      Model Identifier: MacBookPro5,1
      Processor Name: Intel Core 2 Duo
      Processor Speed: 2,4 GHz
      Number of Processors: 1
      Total Number of Cores: 2
      L2 Cache: 3 MB
      Memory: 8 GB
      Bus Speed: 1,07 GHz
      Boot ROM Version: MBP51.007E.B06
      SMC Version (system): 1.33f8
      Sudden Motion Sensor:
          State: Enabled

Software:

    System Software Overview:

      System Version: OS X 10.8.2 (12C60)
      Kernel Version: Darwin 12.2.0
      Time since boot: 11 minutes

Graphics/Displays:

    NVIDIA GeForce 9400M:

      Chipset Model: NVIDIA GeForce 9400M
      Type: GPU
      Bus: PCI
      VRAM (Total): 256 MB
      Vendor: NVIDIA (0x10de)
      Device ID: 0x0863
      Revision ID: 0x00b1
      ROM Revision: 3437
      gMux Version: 1.7.3

    NVIDIA GeForce 9600M GT:

      Chipset Model: NVIDIA GeForce 9600M GT
      Type: GPU
      Bus: PCIe
      PCIe Lane Width: x16
      VRAM (Total): 256 MB
      Vendor: NVIDIA (0x10de)
      Device ID: 0x0647
      Revision ID: 0x00a1
      ROM Revision: 3437
      gMux Version: 1.7.3
      Displays:
        Color LCD:
          Display Type: LCD
          Resolution: 1440 x 900
          Pixel Depth: 32-Bit Color (ARGB8888)
          Main Display: Yes
          Mirror: Off
          Online: Yes
          Built-In: Yes

Audio:

    Intel High Definition Audio:

      Audio ID: 64

        Headphone:

          Connection: Combination Output

        Line Input:

          Connection: Combination Input

        Speaker:

          Connection: Internal

        Internal Microphone:

          Connection: Internal

        External Microphone / iPhone Headset:

          Connection: 1/8-Inch Jack

        S/PDIF Optical Digital Audio Output:

          Connection: Combination Output

        S/PDIF Optical Digital Audio Input:

          Connection: Combination Input

    Devices:

        Built-in Microphone:

          Default Input Device: Yes
          Input Channels: 2
          Manufacturer: Apple Inc.
          Current SampleRate: 44100
          Transport: Built-in

        Built-in Input:

          Input Channels: 2
          Manufacturer: Apple Inc.
          Current SampleRate: 96000
          Transport: Built-in

        Built-in Output:

          Default Output Device: Yes
          Default System Output Device: Yes
          Manufacturer: Apple Inc.
          Output Channels: 2
          Current SampleRate: 48000
          Transport: Built-in


What can I do?
Steam cache files are ok...

thanks!

EDIT:
I was playing in window mode. Playing in fullscreen works fine, but it crashes after a couple of seconds.
I think I'll install it on windows, too many crash on macosx
14 Comments - Linear Discussion: Classic Style
  • User Avatar Image
    DjNDB Moderator
    I just reread your initial post.
    The game also crashes if you run it at full screen no matter what scene?

    That's suspicious. It might indeed be an issue with not having enough VRAM. You have 256MB per graphics chip, but it is recommended to have at least 512MB for one chip.
    What you can try there is setting every graphics setting to the lowest value possible or if available "off". Also choose the lowest resolution available.

    Then try if you can run in full screen.

    Also try if you can chop the leg with these settings.

    You can further try if anything changes if you use the GeForce 9400M instead of the NVIDIA GeForce 9600M GT.
  • The first time that I've tried in fullscreen it didn't crash on the "chop the leg" scene but after a couple of seconds.
    Now I'm trying in fullscreen mode again (and again and again) and it crashes as always at the second chop.

    Thanks for the suggestions, of course I've tried it before: low settings, different graphic card (also if 9600M is more powerful then the 9400M)... but nothing, it still crashes!
    Now I'm deleting and reinstalling it... I think it's the only thing that I can try.
    Anyway I'm installing it also in a windows virtual machine... Hopefully it will works fine :)
  • User Avatar Image
    DjNDB Moderator
    JJSaccolo wrote: »
    Anyway I'm installing it also in a windows virtual machine... Hopefully it will works fine :)

    Sad it didn't work out. Since you have low VRAM already and Virtualization slows down, I'd also recommend trying to run Windows via Boot camp.
  • DjNDB wrote: »
    Sad it didn't work out. Since you have low VRAM already and Virtualization slows down, I'd also recommend trying to run Windows via Boot camp.

    Yes, of course! I'll give it a try with a virtual machine (too lazy to reboot :P ), if it doesn't work I'll play it in my bootcamp partition!

    Thanks :)
  • I have the same problem running the game on a Mac with Steam.

    I happended 6 or 7 times in the Motel in Episode 1, then 3 or 4 of times on different moments during Episode 2, and now I'm stuck at episode 3. It freezes when I enter the train station.

    It always happends when a cinematic is starting or about to start. I play with all the graphic settings on low and ussually after restarting one or two times it works, but not this time.

    ¿Can you offer any help? I'm really liking this game, and I really want to see how it ends :)
  • User Avatar Image
    DjNDB Moderator
    enriguti wrote: »
    I have the same problem running the game on a Mac with Steam.
    -rw-r--r-- 1 Enrique staff 17K 19 feb 22:53 /Users/Enrique/Library/Application Support/Steam/SteamApps/common/The Walking Dead/TheWalkingDead.app/Contents/Resources/Pack/default/prefs.prop
    -rw-r--r-- 1 Enrique staff 38K 19 feb 22:53 /Users/Enrique/Library/Application Support/Telltale Games/TheWalkingDead/prefs.prop

    I am not sure if it helps with the crashes, but you do have multiple prefs.prop files which are out of sync. Here's something you can try:

    Please disable steam cloud for TWD (In Steam, right click TWD and select "properties". Open the tab "updates" and remove the checkbox from "Enable Steam cloud synchronization for TWD").

    Then run the commands below in a Terminal.
    Rename the prefs.prop in the install folder:

    mv ~/Library/Application\ Support/Steam/SteamApps/common/The\ Walking\ Dead/TheWalkingDead.app/Contents/Resources/Pack/default/prefs.prop ~/Library/Application\ Support/Steam/SteamApps/common/The\ Walking\ Dead/TheWalkingDead.app/Contents/Resources/Pack/default/prefs.prop.orig

    Prevent the creation of multiple prefs.prop files by creating a symlink:

    ln -s ~/Library/Application\ Support/Telltale\ Games/TheWalkingDead/prefs.prop ~/Library/Application\ Support/Steam/SteamApps/common/The\ Walking\ Dead/TheWalkingDead.app/Contents/Resources/Pack/default/prefs.prop
  • DjNDB wrote: »

    mv ~/Library/Application\ Support/Steam/SteamApps/common/The\ Walking\ Dead/TheWalkingDead.app/Contents/Resources/Pack/default/prefs.prop ~/Library/Application\ Support/Steam/SteamApps/common/The\ Walking\ Dead/TheWalkingDead.app/Contents/Resources/Pack/default/prefs.prop.orig

    After doing this I did get the Rewind opcion back (thank you :) ) but the crashes still ocurr
    DjNDB wrote: »


    Prevent the creation of multiple prefs.prop files by creating a symlink:



    ln -s ~/Library/Application\ Support/Telltale\ Games/TheWalkingDead/prefs.prop ~/Library/Application\ Support/Steam/SteamApps/common/The\ Walking\ Dead/TheWalkingDead.app/Contents/Resources/Pack/default/prefs.prop[/SIZE]

    I can't do this, it always says 'No such file or directory' ¿?

    But it does seem I now have 2 different pref.prop files

    -rw-r--r-- 1 Enrique staff 18K 20 feb 00:42 /Users/Enrique/Library/Application Support/Steam/SteamApps/common/The Walking Dead/TheWalkingDead.app/Contents/Resources/Pack/default/prefs.prop.orig
    -rw-r--r-- 1 Enrique staff 38K 20 feb 08:00 /Users/Enrique/Library/Application Support/Telltale Games/TheWalkingDead/prefs.prop
  • User Avatar Image
    DjNDB Moderator
    The prefs.prop.orig is the one we renamed to disable it.

    It is likely that the crashes are not prefs.prop related then, but at least we fixed the rewind issue.
    I don't know any reliable fix for the crashes. You can try if uninstalling and reinstalling TWD helps.

    Just to be sure make a backup copy of your savegame folder first:

    cp -R ~/Library/Application\ Support/Telltale\ Games/TheWalkingDead ~/Library/Application\ Support/Telltale\ Games/TheWalkingDead.backup
  • I tried uninstalling and reinstalling the game but the problem continues. This time I did get trough one more cienematic but it now stops at the next one.

    What can I do?
  • User Avatar Image
    DjNDB Moderator
    I fear I am out of reasonable ideas.
    One last thing you could try is if running the game in windowed mode helps.

    If it doesn't, you could send a support request to support@telltalegames.com. Maybe they have more insight into the crash issues.
This discussion has been closed.