User Avatar Image

XBLA version, how do i solve the problem

posted by Joel111 on - last edited - Viewed by 1.4K users
I bought the Walking Dead two days ago. Bought all five episodes and downloaded off Xbox live with no problems. I play through episode 1 and go on to episode 2 with no problems, I let the credits roll to episode 2 and click play for episode 3 and it takes me back to episode 1. It keeps happening.

I've got the stats for both episode 1 and 2 which means its completed and decisions made right? What am I meant to do now, I didn't even turn my xbox off it; i just completed episode 2 and now it just keeps playing episode 1 instead of 3.

I read MattP's post about an automatic prompt for an update to solve this problem but that hasn't happened and copying the save into the third slot hasn't made one bit of difference. What am i meant to do? I know there are loads of threads like this but none have helped and the problem still persists so what can I do to progress Telltale?

15 Comments - Linear Discussion: Classic Style
  • Nobody is getting support. The fact that any of these bugs haven't been fixed is a fuckin' joke.
  • The fact that this problem is FUCKING KNOWN....and they are STILL letting people PAY and download the game IS FUCKING ROBBERY!!!!

    Got stung last night, downloaded 4 episodes and I can only play two...Bravo you THIEVING FUCKS!!!!
  • There's no need to yell, im sure telltale isnt sitting around the water cooler laughing at us.
    Apparently there is supposed to be a title update that is supposed to fix the problem. Your xbox is supposed to download it automatically, but it doesn't come up for me. I checked my hd it doesnt have the title update in there. Everything i've been able to find just says there is a title update that is supposed to download automatically, but nothing about what to do if that isnt the case. I downloaded an update for another game since ive been having this problem and that worked just fine. so i know my xbox is fine. I've uninstalled the game and reinstalled it still nothing.
    Needless to say i share your frustration.

    Edit: I also cleared the system cache, then redownloading it, tried starting ep3 with random choices still nothing worked.
  • Yeh my xbox didn't download anything automatically either, and I can't find any title update to download... Still got the same problem after trying to restart the game a few times.
  • Same problem, same story
  • I have every right to be angry and yell. They are willingly selling an inferior product for profit
    With knowledge that it is not working. The only reason i know this
    Isnt working is i had to find out myself, take a look at the board this has been going
    On for months, yet your still able to download episodes you cant play and they know you will
    Lose the saves you spent time creating.

    Ask yourself, why didnt they take this game off xbla until the problem was resolved?

    So even once a solution is finally realised, i will still be unhappy. You and i and a lot of people here have been knowingly ripped off
  • Exactly the same here, I have read articles online about how they are making sure the season 2 will be less buggy but what about people who can't even get half way through season 1 and not being able to play what has been paid for..
  • Same problem here too, hopefully they have this fixed soon.

    keep a back up to copy over any glitched saves

    1. once you complete chapter 2 and the credits are done go to your stem memory options...DO NOT START THE NEXT CHAPTER

    2. delete chapter 2, NOT YOUR SAVE

    3. delete chapters 4, and 5

    4. reload the game and start chapter 3 SHOULD load it fine

    5. when you complete chapter 3 and the credits are done delete chapter 3 and redownload chapter 4

    6. rinse and repeat

    found this my self. I will make sure to never pay money for any game you have a part in for the rest of my life, same goes for my family and friends....
  • Will try that when I am home mate, thanks...

    telltale, do you fancy commenting on this problem? Or atleast acknowledge that you are working on it or are aware of it?
This discussion has been closed.