User Avatar Image

Only WITHOUT the title update I can continue past the 'Select a Device' screen.

posted by Netwin on - last edited - Viewed by 754 users
Since the title update I get the error message "Error: The device containing the game has been removed. Press A to return to the Xbox 360 Dashboard.". The happens right after the "Select a Device" screen.

If I clear the cash and refuse the title update I can play the game. As soon as I accept the title update again the message appears.

I was not too far into the game so I wanted to solve this by starting fresh. I downloaded the game and all episodes to my hard drive through the download history, cleared the cache and deleted my game save data. I accepted the title update. The message still appeared.

It appears that I can only play the game without the title update. How can I solve this? I don't mind completely restarting.

Thanks in advance!

Edit: A moment ago I have tried to play the game with all the files both on my hard drive and USB storage device simultaneously and even then the error message came up.

What happens if I play the game without any title updates? I don't know if there had been any before the latest one, but I have lost them all by clearing the cache. If there were any, is there a way to get the title update before this last one that doesn't let me play the game? Are there any game breaking bugs in the first episodes that are avoidable? I am thinking of playing through the first episode to find out if the latest title update works if you continue in the second episode, but in that case I don't want to loose any progress.

Can I expect another future title update that will address this issue and when is it due?
2 Comments - Linear Discussion: Classic Style
  • My problem is solved! It now just works :)

    The following has changed; Yesterday while I was using Xbox Music I got suddenly disconnected from Xbox Live. I did the network connection test and it suggested that I should restart my router. I did. When I tried the Walking Dead yesterday evening to show the error message to someone it all of a sudden worked. I tried again this morning and it still worked.

    I suspect that restarting my router solved it. Now that it works the game displays the following after the “Select a Device” screen:
    “Refreshing episode status.”
  • Hello I'm having the same issue you had, whenever I try to play the game I get the error message (storage device disconnected). Could you please give me a detailed version of how you fixed your problem thank you :)

    For example was your xbox on while you restarted your router ect.. :)
This discussion has been closed.