User Avatar Image

"Storage device lost"

posted by Luizao876 on - last edited - Viewed by 22.1K users
For some reason, everytime I play Episode 5, and when it is on loading, this pops on:

"The storage device was removed while saving or loading. The game will now exit to the title screen."

Then, when I restart to where I was, it never loads, it stays in a black screen and never loads.

Does Telltale or someone knows the solution for this?
157 Comments - Linear Discussion: Classic Style
  • Also just tried clearing my system cache, no luck. Same error message when I get to "Trapped" in Act 5.

    Tried deleting the Title Update and then clearing my System Cache, and also no luck. Crashed during "Siege" again.
  • It would be nice to get even a "we are looking into this" from Telltale but I expect they are too busy polishing all those awards to care about the customers.
  • They're not busy polishing anything. They're busy rolling around in the money they scammed from people selling an unfinished game.
  • The thing is I hate being negative about this game. I loved every second of it while playing.

    So to now be blocked from replays is simply awful. Even more so because Telltale don't seem to care.

    I know they are a relatively small studio, I know they have other projects on the go, but come on. At least pay lip service to getting a previous title running for those who can't play it.
  • I've got this problem now, its at the part when you leave the Stranger's room in Episode 5. Telltale aren't helping anyone?

    Edit: When I click Continue it takes me to a black screen and nothing happens, I have restarted the Stranger section 2 times now and the same thing happens. This is really annoying.
  • I haven't been able to play since 2012 now. This is ridiculous; Telltale's incompetence has made it so I haven't been able to play this game for over 9 months.

    There are certain points in the game that universally cause a 'Storage Device Lost' error to pop up, the first point being the bit in Episode 1 where you're just about to start clearing the motel to save that woman. There's another point in Episode 5, just before you enter the Marsh House. I don't know about any other points, but they probably exist throughout each Episode.
  • I get it right after the Telltale/Skybound screen. The game won't even start. I re downloaded every episode and the update. Restarted my Xbox, modem and router. Everything is now and always has been on my HDD which has not been removed since before TWD even came out and I have never transferred my account. Everything was originally downloaded to this same profile and xbox. Whats's going on? I really want to make some decisions!
  • I also have this recurring problem. I wanted to get three different saves completed before 400 days came out (already had the 1st two done), and on the 3rd save, I made it all the way through to The Gauntlet chapter of episode 5, when it popped up with the storage device removed message and crashed.

    I gave in and downloaded 400 days anyway and played it continuing on from my 1st save, and worked fine until the 4th character's epilogue (Bonnie's in my case), when it popped up with the same message again. Based on some of the suggestions on the related threads on here, I tried moving my save to cloud storage, which did nothing, and then I deleted off the 3rd save I had. Once I did this, it was temporarily fixed but I only got halfway through the 5th character's epilogue (Russell for me) before it popped up again.

    Telltale, a fix would be mightily appreciated.
  • I having played in awhile because of this problem as well I thought they would have fixed this before the DLC have to say Telltale this is some bullshit
  • If this issue has been around since November of last year, and it's the same problem I just encountered with 400 days, I am VERY concerned with the lack of communication on the part of Telltale
This discussion has been closed.